Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

AMPLI DIY DUAL LM3886 TENSION/COURANT - bi/tri amp asservi

Message » 03 Mar 2015 9:50

Au niveau du bruit, j'ai un HP de 95db de rendement connecté à l'ampli, il faut que je colle mon oreille au HP pour entendre un très, très léger bruit de fond.
En attendant j'alimente l'ampli avec 2 régulations à LM 317 + transfo.
Jean-Philippe
razzortec
Membre HCFR
Membre HCFR
 
Messages: 1287
Inscription: 05 Fév 2008 22:25
Localisation: 68
  • offline

Annonce

Message par Google » 03 Mar 2015 9:50

Publicite

 
Encart supprimé pour les membres HCFR

Message » 03 Mar 2015 10:02

Bonjour Razzortec, merci pour le retour d'info, tu parles d'un bruit blanc/rose type schh, pas de hum ? est ce que tu as un long câble ?
comme il y a 2 amplis sur la carte , l'idéal serait d'en câbler un en mode tension et de comparer les différences entre les 2 . Probablement qu'un ampli en courant est intrinsèquement plus bruyant, puisque le HP et son câble font partie de la boucle de réaction... en plus de la linéarisation dans la bande utile, il faut peut être optimiser la bande passante ou le gain de boucle en fonction du driver
le topic du Firstone LC un ultime ampli diy
maxidcx
Membre HCFR
Membre HCFR
 
Messages: 1739
Inscription: 25 Avr 2007 10:50
  • offline

Message » 03 Mar 2015 13:04

En attendant j'ai qu'un seul ampli cablé en courant
Sur l'osciilo, ce bruit ne réprésente que quelques mV.
Absolument rien d'alarmant
Jean-Philippe
razzortec
Membre HCFR
Membre HCFR
 
Messages: 1287
Inscription: 05 Fév 2008 22:25
Localisation: 68
  • offline

Message » 03 Mar 2015 18:02

Une mesure de la sortie avec un scope ( sonde blindé), échelle 20 mV/ division ( Je peux pas aller en dessous)
sortie.PNG
sortie.PNG (17.38 Kio) Vu 1212 fois


J'ai meme branché une compression avec 105 db de rendement, j'entends rien :wink:
Jean-Philippe
razzortec
Membre HCFR
Membre HCFR
 
Messages: 1287
Inscription: 05 Fév 2008 22:25
Localisation: 68
  • offline

Message » 03 Mar 2015 22:26

tu es sure qu'elle avait son pavillon :wtf: :mdr:

bon j'ai fait mon propre modèle "AC" pour le 49720 pour être sur de coller pile poil à la datasheet.
Concernant la linéarisation de la courbe I=f(u)... en bricolant la simulation je me suis aperçu que la capa C22 pouvait jouer un rôle comparable à C68. Sur la base des schéma LTSpice donnés dans les posts précédents, avec C68=22n+RC68=10ohms et C22 aux alentour de 8n, on obtient une courbe très plate à 0.5db près, sans avoir besoin de contre réaction en tension (R48+C55) ce qui donne l'avantage de remonter l'impédance de sortie d'au moins 10db.
Et la courbe de LoopGain s'en porte mieux, avec beaucoup moins de risque d’être à 0db sur le premier -180°

Les valeurs n'ont pas d’intérêt car elle doivent être ajustée par rapport à RE et LE, mais en jouant sur ces 2 capas C22 et C68 on peux linéariser tout en optimisant l'impédance de sortie.
Jean Claude, puisque tu as la main sur les fichiers d'origine, tu pourrais vérifier sans difficulté et peut être confirmer cette approche ?

Concernant l'influence du DC Servo, il est clair sur la courbe d'impédance qu'il réduit la résistance de l'ampli à partir de 200hz environ (en allant vers la gauche). donc cela réduit la capacité à maitriser précisément l'accélération aux basses fréquence. Grosso modo à 50hz on aura 4 fois moins de resistance de sortie qu'à 1khz. Toute la difficulté en l'état actuel de l'expérience est de savoir qu'elle sont les valeurs idéales ou optimales, en fonction du driver.

Razzortec, c'est quoi l'idée que tu as en tête maintenant que tu as un ampli courant qui ne fait pas de bruit ? :mdr:
Androusky,XqutR, vous pensez vous lancer dans le montage ? n'hésitez pas à demander conseil, y compris pour la BOM et l'ajustement des valeurs à vos HP
:thks:
le topic du Firstone LC un ultime ampli diy
maxidcx
Membre HCFR
Membre HCFR
 
Messages: 1739
Inscription: 25 Avr 2007 10:50
  • offline

Message » 04 Mar 2015 10:09

maxidcx a écrit:Razzortec, c'est quoi l'idée que tu as en tête maintenant que tu as un ampli courant qui ne fait pas de bruit ? :mdr:
Androusky,XqutR, vous pensez vous lancer dans le montage ? n'hésitez pas à demander conseil, y compris pour la BOM et l'ajustement des valeurs à vos HP
:thks:


En ce qui me concerne, j'aimerais éviter le mille feuille de HUM. Donc à moyen terme la réponse est plutôt non ; il faut d'abord déterminer le pb avec le classe A d'Esa... j'envoie le paquet à Razzortec ajd, je viens de rentrer. D'une façon + générale : le projet de petit classA m'a permis de savoir jusqu'où ne pas aller trop loin quand on joue à la limite de ses compétences, et là je suis clairement allé trop loin :oldy:
Y a pas un peu trop de fumeurs de moquette par ici ?
androuski
Membre HCFR
Membre HCFR
 
Messages: 14805
Inscription: 14 Mar 2007 14:43
  • offline

Message » 04 Mar 2015 11:17

Nicolas, ne t'auto flagelle pas!
Ton manque de compétence est surtout dans le choix du mouton à 5 pattes que tu veux terrasser!

Le montage de Esa est très particulier, instable et ne mérite pas d'y passer des heures amha.
Il y a bien plus simple, fiable et performant pour se faire la main.
Philby
 
Messages: 9607
Inscription: 12 Mar 2001 2:00
Localisation: 33
  • online

Message » 04 Mar 2015 13:35

Philby a écrit:Nicolas, ne t'auto flagelle pas!
Ton manque de compétence est surtout dans le choix du mouton à 5 pattes que tu veux terrasser!

Le montage de Esa est très particulier, instable et ne mérite pas d'y passer des heures amha.
Il y a bien plus simple, fiable et performant pour se faire la main.


Merci pour ces encouragements Philby :wink:
Je regrette un peu d'avoir pris cette option effectivement... surtout qu'en matière de petit classe A j'avais aussi l'option Zenquito, dans un tiroir. M'enfin on va pas refaire l'histoire.
Y a pas un peu trop de fumeurs de moquette par ici ?
androuski
Membre HCFR
Membre HCFR
 
Messages: 14805
Inscription: 14 Mar 2007 14:43
  • offline

Message » 04 Mar 2015 18:03

Bonjour Maxidcx
La refonte du forum, m'a un peu écarté de ce sujet. J'étais un peu perdu dans ce foutoir nécessaire et j'espère salvateur. Grippé, je n'avais pas vraiment la volonté de chercher.
Jean Claude, puisque tu as la main sur les fichiers d'origine, tu pourrais vérifier sans difficulté et peut être confirmer cette approche ?

Malheureusement, je ne pense pas que le modèle du LM3886 soit suffisamment fiable pour donner un avis ferme.
Le seul but a atteindre est d'avoir une réponse I=f(Ve) la plus étendue possible.
Il serait bon que Razzortec, s'il le veut bien, rassemble sur un schéma, les modifs qu'il a opéré. Il me semble que cela aiderait pas mal de gens.
J-C.B
 
Messages: 5012
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

Message » 05 Mar 2015 18:17

Pas de beaucoup de modifications par rapport au schéma d'origine
Un seul canal cablé

Au niveau des options

Etage d'entrée:
-Pas de That ou d'INA, donc entrée asymétrique
-remplacement des résistances R22/24 par des résistances de 560 ohms
- Pont entre la masse de l'entrée et la masse de l'ampli

Etage ampli
Cablé en courant
C68: 22nF + résistance de 100 ohms en série
En attendant j'utilise un TL072
Résistance de pied de 0.5 ohm 15W

Alim
Pas d'alim Nazar
Résistance R41/42 de 0.1 ohms
Rajout de capa 150µF après les résistances R41 et 42

Servo DC
Remplacement des résistances de 1M par des 470k
Également un TL072


Protection
Pas encore cablé , j'attends les UPC

Le restant est conforme au schéma de maxidcx
Jean-Philippe
razzortec
Membre HCFR
Membre HCFR
 
Messages: 1287
Inscription: 05 Fév 2008 22:25
Localisation: 68
  • offline

Message » 05 Mar 2015 19:13

Merci razzortec :bravo:
J-C.B
 
Messages: 5012
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

Message » 05 Mar 2015 20:41

razzortec a écrit:Etage d'entrée:
-Pas de That ou d'INA, donc entrée asymétrique

:grr:

mais bon :wink:

je ne t'avais pas fourni d'upc avec le pcb ??? peut etre un oubli, j'en avait une dizaine...
le topic du Firstone LC un ultime ampli diy
maxidcx
Membre HCFR
Membre HCFR
 
Messages: 1739
Inscription: 25 Avr 2007 10:50
  • offline

Message » 12 Mar 2015 16:34

J'ai reçu les UPC, je continue le cablage
Jean-Philippe
razzortec
Membre HCFR
Membre HCFR
 
Messages: 1287
Inscription: 05 Fév 2008 22:25
Localisation: 68
  • offline

Message » 22 Mar 2015 19:16

Bonjour a tous,
voila un post pour partager des résultats de mesure avec le module add-on amplificateur différentiel x1000 (+60db)

tout d'abord la photo de l'ampli, surmonté de la carte add-on:
Image
La carte est reliée sur le connecteur 8 broches de l'ampli qui lui fournit l'alimentation +/- 15V ainsi que la masse du signal analogique.
L'ampli différentiel AD8429 est relié sur un connecteur BNC ce qui permet d'avoir une liaison vers l'oscillo bien propre.
Les dip-switch (rouge) permettent de relier les entrées de l'ampli de mesure avec soit la sortie du that ou le gnd ou les rails d'alim, ou vers le connecteur 3 point qui est relié sur la sortie de l'ampli (fil rouge entre borniers à gauche et carte addon).

EDIT: suppression des FFT, je viens de faire une campagne de mesure
le topic du Firstone LC un ultime ampli diy
maxidcx
Membre HCFR
Membre HCFR
 
Messages: 1739
Inscription: 25 Avr 2007 10:50
  • offline

Message » 22 Mar 2015 22:08

voici donc les mesures, qui sont interressantes mais finalement pas très excitantes pour le mode "courant":

Cette première mesure montre la qualité du système de mesure, puisque les entrées de l'ampli de mesure différentiel sont reliées à la masse analogique (à un point qui se trouve au niveaux des That), donc:
Image


Cette mesure correspond au niveau de bruit sur le rail d'alimentation +15V et la suivante sur -15V. On peux voir sur la deuxième que la réjection du 100khz venant de l'alim à découpage et donc un peux moins bonne que sur le rail positif (pour environ 6 à 10db), ce qui logique puisque le LM337 est moins bon que le 317.
Image
Image


Cette mesure représente le bruit en sortie des 2 that1200, leurs entrée étant court-circuitées et reliée à la masse. le "noise floor" est donc plus haut que celui de l'alim, à -95db environ (soit 1lsb sur un DAC 16bits), mais bonne nouvelle, les pics de l'alim à découpage ne sont pas présents:
Image
Image


Cette mesure donne le niveau de bruit à la sortie de l'ampli, câblé en mode courant, avec un résistance de charge de 4ohm directement câblée sur le bornier, et une résistance de pied pour la mesure de 0.5ohms.
Le gain de l'ampli de mesure différentiel est de 60db et de 40db sur la seconde image.
Le niveau de bruit est d'environ -81db et le pic de l'alim est quand même présent à -60db...pas glop. Sur la deuxième mesure moins amplifiée, le pic 100khz est semble t'il noyé dans le bruit et la FFT de l'oscillo semble avoir donc plus de mal à l'extraire. il ne fait donc pas prendre cette valeur de -74db à la lettre. (de toute façon 100khz ne s'entend pas :mdr: )
Image
Image


Les 3 mesures suivantes sont faites sur une charge Résistance 9.4ohm+Self 200uH avec un câble torsadé d'une 20 aine de centimètre:
Première image avec l'ampli configurer en mesure de courant sur la résistance de pied,
Deuxième image, le courant est mesuré en différentiel sur une résistance plus faible de 0.22ohms (donc gain de boucle plus élevé de 7db).
On voit une forte remontée du bruit jusqu'à 40khz puis ça redescend. Donc la linéarisation du courant n'est pas correctement adaptée.
Le pic 100khz ressort fortement. Il est moins important en mode différentiel, mais malheureusement dans ce cas le niveau de bruit est plus élevé...
Image
Image

Dernière image mesurée sur l'autre ampli, en mode tension, chargé par le même montage R+L.
Image

tout cela n'est donc pas exceptionnel ...
le topic du Firstone LC un ultime ampli diy
maxidcx
Membre HCFR
Membre HCFR
 
Messages: 1739
Inscription: 25 Avr 2007 10:50
  • offline


Retourner vers Amplis et Préamplis

 
  • Articles en relation
    Dernier message