Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités

Gain Clone – Projet LM3886 « GD »

Message » 30 Jan 2013 12:48

Bonjour les gars,

il y a quasiment 2ans j'ai lancé un projet d'ampli a base de LM3886 qui a dérivé vers le TDA7294, et qui au final a terminé en eau de boudin :ko:
ce beau projets s'appelait "Projet Fast Back".

pour ceux qui aiment lire :
diy-amplification/un-nouvel-ampli-diy-fastback-t29959864.html#p174508094

Suite à ces déboires, j’ai décidé de m’y remettre mais en faisant quelque chose de moins ambitieux.
A l’heure ou j’écris ces lignes l’ampli n’est pas finalisé (mesures de disto non encore effectuée).

KESAKO LM3886 GD
GD pour Gentillement "Drivé".
ET oui … plutôt que FAST back (retour rapide), j’ai opté pour le mode (Doucement dirrigé/conduit.. ;)
Pour faire simple Le LM3886 a un gain assez faible, et est « drivé » en amont par un AOP avec un faible GAIN.

en gros le schéma c'est CA :
Image

LM3886 GD-1
La grosse différence par rapport au « Fastback », c’est qu’il n’y a plus la CR globale.
Ici le signal est d’abord amplifié par l’aop avec un gain de 4.9V/V, et ce signal est ensuite amplifié en tension et en courant avec un gain de 7.8V/V

Les étapes qui ont menées a ce schéma « simpliste »
1. le choix de l’AOP.
L’AOP choisi est un LME49720 (LME49710 Double).
Cet AOP est n plus ni moins que le très célèbre LM4562.
C’est un bon AOP a faible bruit, faible disto et faible offset.
Le choix de cet AOP a été fait parmi un beau pannel (AD, LM, NE, TL, OP,….)
Au final le LME 49720 m’a donné de bon résultats y compris coté offset, ce qui mermet de nous affranchir du condo dans la CR de L’AOP.
Pour l’instant je n’est pas mis de filtre haute fréquence en entrée, car il n’y en a pas besoin au vu de ce que j’ai pu voir à l’oscillo. Cependant au final il y aura un petit condo de quelques dizaines de pF après la résistance de 1k (cette résistance sera certainement revue a la baisse … j’en sais rien pour l’instant).

2. L’ALIM de l’AOP.
Comme Le Circuit peut être alimenté en 35VDC ou plus j’ai préféré éviter les régulateurs classiques (LM7815/7915/LM317/LM337).
Je suis donc parti sur une régul maison a base de TL431.
Il est a noter que la stabilité de cette alim m’a donné du fil a retordre.
Les montages sur plaque d’essais fonctionnaient parfaitement … mais une fois sur un beau PCB sans Capacité parasite … ben ca oscillait sévère. Ce qui fait que le PCB original n’a pas certaine compensations qui ont étés mise lors de la phase de tests.

Image

Concernant cette alimentation …
Cette régulation est connectée a l'alim générale de l'ampli via des diodes + condos "réservoirs".
La partie positive n’est pas extraordinaire, mais on notera
    a. l’utilisation d’un BD139. En général on met a cette place des darlingtons, mais vu les courants consommés par un AOP, le gain en courant du BD fait largement l’affaire.
    b. Le TL431 est chargé a 10mA (optimisations des performances)
    c. Le TL431 est « bridé » par un 10nF sur la CR – absolument nécessaire (au minimum 1nf) suivant ce qui est mis en sortie d’l’alim (tests de stabilité de l’alim).
    d. Un peu d’originalité avec un 10µF en parallèle de la 15k (idée reprise de chez TNT : http://www.tnt-audio.com/clinica/regula ... se3_e.html) efficacitée impressionnante.
La partie négative de l’alim est un peu plus non std
    a. Le TL431 n’ayant pas pour vocation de travailler dans le domaine « négatif », l’utilisation d’un BC560c permet de le faire.
    b. Pour le reste on est identique a la partie Positive.
    c. Il est a noter que la partie négative était plus instable que la partie positive. J’ai du mettre un 10nF pour éviter à l’alim d’osciller.

Note : Je sais … c’est un peu beaucoup pour un AOP, mais encore une fois ca a été l’occasion d’apprendre !

3. Le LM3886
Cette puce est hyper connue et n’a plus rien à démontrer….
En théorie le datasheet préconise des gains supérieurs ou égaux a 10V/V.
J’ai opté pour un gain plus faible suite à une série de tests de stabilité. (je détaillerai cela plus tard)
Pourquoi n’avoir pas attaqué le LM3886 par les entrées inverseuses ??? parceque j’ai toujours l’idée de re tester le « fastback »… et pour faire un fastback il faut que les AOPs du schéma soient attaqués par les entrées non inverseuses.
En regardant le schéma on s’aperçoit que chacune des entrées (inverseuse et non-inverseuse) du LM3886 est raccordé à la masse via des impédances assez proche – ce qui devrait limiter l’offset du dit LM3886 ( à la simul c’est impressionnant). Dans la pratique j’observe un offset en sortie très faible (2.4mv) si le condo de 220uF n’est pas mis, malheureusement j’ai constaté que cet offset variait en fonction de la sollicitation en courant du LM3886. En effet après avoir fait chauffer le LM3886, l’offset global monte à 15-20mV (rien de grave) et j’ai préféré mettre le condo dans la CR du LM3886.

Aucune compensation n’est nécessaire ou que ce soit … (ni pour brider le LM3886 ni le LME).

Coté TYPON, J’ai découplé au maximum les Alims du LM3886 comme préconisé. J’ai eu un souci certainement avec les courants forts qui polluaient l’entrée de l’ampli. J’ai corrigé le problème en connectant directement le point froid de l’enceinte sur le 0V de l’alim, et en ajoutant une petite résistance entre le 0V signal et le 0V ALIM.

EVOLUTION …. Utiliser l’autre partie du LM49720 pour faire un DC Servo … OU Mettre un autre AOP pour faire un DC Servo.

4. L'alimentation de l'Ampli :
transfo Rcore de 300VA / 24AC
2 ponts de diodes 35A / 600V
4 condensateurs 10000µF/63V RIFA Low ESR

sur le PCB de l'ampli il y a 2 condos 4700µF/63V SIC SAFCO.

La Suite Après ….
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Annonce

Message par Google » 30 Jan 2013 12:48

Publicite

 
Encart supprimé pour les membres HCFR

CIRCUIT TYPON

Message » 30 Jan 2013 12:49

Les schémas :

L'alimentation globale de l'ampli :
Image

Notes :
a. les diodes utilisées pour le redressement de l'ampli ne sont pas des 1N4007, mais des MB156 (pont de diode boitier 15A/600V ou 30A/600V)
b. les condos 10mF sont des RIFA LOW ESR.
c. les condos 4.7mF sont des SIC SAFCO LoW ESR.
d. Les condos 220µF ne sont pas des LOW ESR, mais ca va ....

L'ampli :
A compléter

Les PCBs
Le PCB V1.0: Dimensions Réelles : 100mm x 80mm
Image

Image
Dernière édition par Yuli_35 le 02 Fév 2013 11:40, édité 4 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Mesures LM3886 et stabilité (Seul).

Message » 30 Jan 2013 12:49

3. Gain = 7.8 (17.85dB)
Configuration Ampli :
Image

Rappels :
Alimentation en +35/-35V
Le LM3886 est donné pour 56W/68W !

Sur signal carré avec une charge de 6.8 Ohms,
on atteint 56W avec un signal crete a crete de 40VPP.
On atteint 68W avec un signal cête a crête de 43VPP.

En conséquence on testera les signaux carrés entre 1VPP et 40-45VPP car – audela de ces valeurs, nous sommes en dehors des specs du LM3886.

Il est à noter que les tests ont été lancés chacuns durant plusieurs minutes.
La charge capacitive consiste en une RC de 0.1 Ohm + 1µF
Il est a noter que dans le datasheet du lm3886 il est recommandé de mettre une self en sortie d’ampli si la charge est trop capacitive.
3.1. Signal Carré 20Hhz
3.1.1. 1VPP 20Hz :
Image

3.1.2. 1VPP 20Hz Charge capacitive
Image

3.1.3. 10VPP – 20hz
Image

3.1.4. 10VPP – 20hz – charge capacitive
Image

3.1.5. 40VPP – 20hz –
Image

3.1.6. 40VPP – 20hz – charge capacitive
Image

3.2. Signal Carré 1kHhz
3.2.1. Signal Carré 1VPP
Image

3.2.2. Signal Carré 1VPP charge capacitive
Image

3.2.3. Signal Carré 57.2VPP (120W !!!) – 1khz
Image

3.2.4. Signal Carré 40VPP – 1khz
Image

3.2.5. Signal Carré 40VPP – 1khz capacitive
Image

3.3. Signal Carré 10kHhz
3.3.1. Signal Carré 1VPP – 10khz
Image

3.3.2. Signal Carré 1VPP – 10khz Charge capacitive
Image

3.3.3. Signal Carré 10VPP– 10khz
Image

3.3.4. Signal Carré 10VPP– 10khz-capacitif
Image

3.3.5. Signal Carré 40VPP 10khz
Image

3.3.6. Signal Carré 40VPP 10khz – Capacitif
Image

3.4. Signal Carré 100Khz
3.4.1. Signal Carré 1VPP – 100khz
Image

3.4.2. Signal Carré 1VPP – 100khz - capacitif
Image

3.4.3. Signal Carré 10VPP– 100khz
Image

3.4.4. Signal Carré 10VPP– 100khz- charge capacitive
Image

3.5. Signal Carré 20VPP– 100khz
3.5.1. Signal Carré 20VPP– 100khz
Image

Sur signal carré au delà d’une certain amplitude, le signal deviant pourrit.
3.5.2. Signal Carré 20VPP– 100khz capacitive
Image

3.6. Hautes Fréquence Charge résistive pure
3.6.1. 400Khz :
Image

3.6.2. Signal Carré 5VPP– 500khz – Charge résistive pure
Image
Dernière édition par Yuli_35 le 30 Jan 2013 14:07, édité 1 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Mesures Alimentation AOP.

Message » 30 Jan 2013 12:49

Mesures Alimentation AOP.

Je ne vais pas rentrer dans tous les détails de l'alimentation régulée des AOPs.
On parle de cette alimentation/régulation là :
Image

Avec mon oscillo je peux voir le signal, ainsi que la thd associée à un signal.

voici le bruit de l'alimentation : (Ampli ne délivrant aucune charge).
ICI on voit le signal de l'alim sur lequel on a supprimé la composante continue. (en rouge le rail positif, en bleue le rail négatif).
Image

On ne voit quasi rien ... l'échelle est de 5mV par division verticale.

ANALYSE THD de l'OSCILLO

quand on alalyse la thd entre 0et 1.2Khz on voit ca :
Image

quand on alalyse la thd entre 2et 30Khz on voit ca :
Image

quand on alalyse la thd entre 30K et 600Khz on voit ca :
Image

en clair ... rien qui dépasse les -96dBV ..; ca veut dire Rien qui dépasse les 15µV !!!!! quelque soit la fréquence !!!!
on a un régulation qui fait son travail- et qui le fait bien . un point c'est tout
Je suis a la limite de la mesure (enfin presque) de mon oscillo (en théorie il descend a -120dBV = 1µV)
Les mesures ci-dessus ont été faites avec aucun signal en enrtrée de l'ampli.
bon ces tests ne disent pas grand chose , car potentiellement il faut comparer ce qu'il y a en entrée et ce qu'il y a en sortie.


Alors demain je m'y colle ... Mesure de l'alimentation en 35V, et mesure de la tension régulée 15V avec Ampli Chargé à 40W par exemple.
Dernière édition par Yuli_35 le 30 Jan 2013 16:55, édité 3 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Mesures GD et stabilité.

Message » 30 Jan 2013 12:50

Mesures GD et stabilité.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

ECOUTES / EVOLUTIONS

Message » 30 Jan 2013 12:50

ECOUTES / EVOLUTIONS
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 30 Jan 2013 15:14

Je vois que tu profite bien de ton temps à la maison :)

Le lme49720 est un bon choix, tu as essayé la version HA ?

Je vais m'en acheter pour mon DAC
Asus Xonar Essence ONE (32bit 352KHz) / Pushpull 5881WXT / Magnepan 1.7
CUDA
 
Messages: 1021
Inscription: 01 Mar 2009 20:45
  • offline

Message » 30 Jan 2013 16:28

Hello,

Les LME que j'utilise sont les LME49720NA (récupéré en sample de chez TI).
mais si tu souhaites des LME49720HA plutot que de les acheter tu peux en avoir 3 en sample chez TI.

Il est a noter que texas instrument propose des samples de pas mal de leurs composants. Cela est bien utile pour faire joujou. J'ai aussi des LME49860 en sample... et pas mal d'autres... les LM3886 sont des samples.
les sample c'est pour bricoler ... alors je bricole ! :oldy:
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 30 Jan 2013 16:57

Je vais essayer d'en avoir :)

Mais il m'en faut plus de 3 ... il m'en faut 9
Asus Xonar Essence ONE (32bit 352KHz) / Pushpull 5881WXT / Magnepan 1.7
CUDA
 
Messages: 1021
Inscription: 01 Mar 2009 20:45
  • offline

Message » 31 Jan 2013 10:34

Yuli_35 quand tu auras bien mis au point ta méthodologie de mesure et ton ampli, il faudra qu'on compare avec mon My-RefC
qui à une organisation différente mais utilise aussi un op-amp et un LM3886.
Ca promet d'être intéressant, surtout que maintenant j'en ai 2 versions : un à alim à découpage et un à alim linéaire.
J´avais la télé, mais ça m´ennuyait. Je l´ai r´tournée... d´l´aut´ côté c´est passionnant
tcli
Membre HCFR
Membre HCFR
 
Messages: 3027
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 31 Jan 2013 11:40

Hello Tcli,

Pour la méthodo de mesure elle est assez simple.
En voià les grandes lignes (pour un ampli intégré de type LM3886 ou TDA)

1. Toujours y aller doucement.
2. Tester module par module (alim, puis regul, puis ALIM+ regul + le truc a alimenter ... etc.)
3. Premier vrai branchement de l'ampli :
    il faudra brancher l'ampli sur une multiprise avec interrupteur (pour pouvoir arrêter rapidement au cas ou...)
    a. shunter son entrée
    b. se débrouiller pour limiter l'appel de courant MAX (branchement en série sur les rails d'alimentation d'une résistance de puissance ou d'une ampoule)
    c mettre une charge "légère" en sortie d'ampli (1Khom par exemple)
    d. tout revérifier.
    e. Mettre un multimètre en mode VDc pour regarder l'offset en sortie.
    f. mettre un Oscillo en sortie d'ampli pour vérifier que l'on a pas d'oscillation (surtout avec des SMPS ...)
    g. Mettre en route et regarder ce qui se passe.
4. si tout s'est bien passé (offset acceptable au fil du temps, pas d'oscillation ou autre ....)
    a. brancher une charge std (5.5Ohm en sortie de l'ampli)
    b. Brancher en entrée d'ampli un géné de signal carré.
    c. Mettre en route et regarder ce qui se passe avec differents niveaux en sortie avec le géné carré. (observer l'overshoot, ou les instabilités).
    Si problème d'instabilité ... ben ... faut replancher sur l'ampli.
5. Si tout s'est bien passé ...
    a. on refait les même tests qu'avant mais avec une charge capacitive.
    et on regarde ce qui se passe....

Ou alors on regarde la marge de phase en comparant le signal en entrée et le signal en sortie d'ampli.
L'objectif est de s'assurer que la marge de phase est suffisante même bien au-dela du spectre audio (a déterminer suivant les amplis ).
Si tout se passe bien on peut dire que l'ampli est STABLE.

6. Tests de disto....
Mentre en entrée de l'ampli un géné SINUS, utiliser ARTA et faire les mesures de disto a différentes puissances.

voilà.

Mais a l'extrème il faudrait lancer une post là dessus ... car je ne suis aps un expert... :ane:

a+ Gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 02 Fév 2013 11:12

Choses promises .. choses dues …
Les mesures de l’alim 15V Regulée de l’AOP sur l’ampli.

ALIM 35V non régulée qui alimente une alim de type TL431 comme précédemment.

voilà ce qu'on voit !
la 35V toute seule le bruit (on voit bien le redressement.)
Image

La THD de l'alim 35V: de 0 a 3Khz
Image

L'alim 15V ... son bruit (échelle 5mv !!!)
Image

THD de 0 à 3Khz
Image

THD de 0 à 30khz
Image

THD de 0à 300Khz
Image

En résumé on peut dire que la régulation fait bien son travail.

On Fait BOSSER l'AMPLI:
Regardons ce qui se passe quand on mets un signal carré en entrée de l’ampli.
Signal de 10Khz d’une amplitude de 30VPP (environ 33W dans mon cas)
Ma charge une résistance de 6.8Ohms (Courant débité par l'ampli = 15/6.8 = 2.2A)
Il est a noter que l’alim 15V delivre le courant dans l’AOP (LME49720).
LA 35V non régulée
La tension en 35V ressemble a ca :
Le 35V : on voit bien la composante en 100Hz et les 10Khz en sur impression.
Image
La 35V : on zoom un peu dans le temps.
Image
La 35V : on zoom encore.
Image

L'ondulation en 10Khz n'est pas monstrueuse (moins de 100mv), par contre les overshoot sont bien visibles Amplitude +1/-1V (front montant a 400Khz+)
L'ondulation en 100Hz à changée par rapport a l'ampli au repos on pase de 30mV a 340mV.

LA 15V REGUL
La régul 15V: On regarde pour voir si il y a du 100Hz .... rien. par contre le 10Khz ... on le voit bien.
Image
On Zoom sur la 15V:
Image
On Zoom encore dans le temps:
Image

moi le truc qui me choque c’est que le 15V est exempt de 50Hz ou même de 100Hz.
la tension régulée a un signal a 10Khz assez faible quelques dizaines de mv.
Par contre l'overshoot est énorme +0.7V/-0.7V avec des fréquences de types 400+Khz.
Pour faire simple l’alim 15V filtre bien la tension mais a du mal a réguler.

Les experts qu’en pensez vous ?

Il est a noter que je n’ai pas mis de condensateurs en sortie des régul .
Je n’ai même pas bypassé le +15V/-15V avec un 100nF comme on fait en général - quand on alimente un AOP.

Ma question : Est-ce normal ? ou y at’il un problème et si oui … que corriger pour améliorer les transitoires ?

Cdlt Gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 02 Fév 2013 12:14

Hello
Pour un ampli je vais essayer ça https://docs.google.com/file/d/0B4AEmEx ... sp=sharing
en régulation c'est nettement moins performant, mais avec une modulation de 10kHz faut voir
C'est à adapter à la tension, 50V dans mon cas.
Cordialement
Roger
Toshiba sd900e, Denon A10SE, McIntosh2505,T-Amp, UCD proto, enceintes DIY jbl2231a jbl 2420 tw Audax annulaire PR130p20hr, Infinity alpha50, infinity Kappa center, plasma pioneer, dac à base de module made in Taiwan
Bobo le Chat
 
Messages: 1776
Inscription: 28 Nov 2005 12:45
Localisation: Lille
  • offline

Message » 02 Fév 2013 14:29

Gilles , je ne sais pas quelle bande passante a ton ampli, mais sans limitation dans la boucle de contre réaction , elle peut être importante.
Du coup , quand tu envoi un carré de 10Khz , il passa aussi les harmoniques très haut en fréquence.
Hors , comme tu l'as montré sur le post des alims, celles ci sont limitée en fréquence et donc il n'est pas anomale quelle ne regulent pas à ces très haute frequences.
Pourrais tu faire une FFT des signaux que tu viens de montrer (regulés et pas régulés )....
J´avais la télé, mais ça m´ennuyait. Je l´ai r´tournée... d´l´aut´ côté c´est passionnant
tcli
Membre HCFR
Membre HCFR
 
Messages: 3027
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 02 Fév 2013 18:19

Hello Roger,

Ta régulation n'est pas vraiment une "régulation".
En réalité ce que tu fais avec ce schéma c'est plus filtrer les bruits de l'ailm en clair tu vires le 50 et 100Hz.
ca va aussi un peu jouer sur l'impact de ce qui est tiré sur l'alim, mais faiblement.
Et c'est aussi pourquoi il y a plein de capa en aval de la dite régulation.

une régulation digne de ce nom est un asservissement qui prend en compte ce qui est en sortie et le compare a une "consigne" pour corriger le tir.
En tout cas ca marchera, ce sera moins performant qu'une vraie régulation, mais ca marchera pour virer la 50/100Hz.

Pour les THDs (Tcli)... je vais les faire.
D'habitude je le fais systématiquement, mais là j'ai fait ca vite et surtout comme j'étais dans une zonne ou ca fait bien chauffer l'ampli / Rad , j'ai préféré ne pas trop fair chauffer le bignou (je balance un signal carré a 10khz de 30VPP. (c'est pas classique et les amplis ca les fait bien chuaffer !).
note : mon ampli (LM3886) a une bande passante > a 500Khz.... (regarde les images postées ci-dessus de ce que donne un signal carré a 500Khz.)


Je vais Faire 2 choses ... les THds, mais aussi ne pas mettre l'AOP. Come ca je ne tirerais rien sur la régul (ou plutot un courant constant.).
je vais m'y coller.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes



Retourner vers Amplis et Préamplis

 
  • Articles en relation
    Dernier message