Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Bing [Bot] et 3 invités

(Petit) Ampli Casque à ampli-op

Message » 12 Aoû 2010 10:23

Comme je n'ai pas trop réussi à le faire fonctionner correctement jusqu'ici, je met les schémas précis que j'utilise. Comme ça s'il y a une très grosse bourde que je n'ai pas vue, je peux la corriger.
Au cas où c'est un peu illisible, les résistances d'émetteurs de la voie de masse sont des 1 ohm.

Comme améliorations, je verrais bien un gain plus élevé, pour plus de stabilité. L'OPA2134PA est stable en gain unitaire normalement, mais avec le buffer dans sa boucle de rétroaction, peut-être qu'un gain de 3 ou 4 lui simplifiera la tâche. Logiquement, je devrais changer les résistances d'émetteurs de la voie de masse par des 25ohm, là ça chauffe vraiment ! Je sortirais bien la résistance de 4.7ohm en sortie de la boucle, c'est une "wirewound" 3Watt... Comme l'a suggéré Yuli, on peut perdre quelques mW avec les casques.

J'en suis aussi à me demander s'il ne faudrait pas virer les résistances de tension d biais de 25ohm.

Que penses-tu de ces changements, et est-ce que tu en voies d'autres ?

L'alim : http://img12.imageshack.us/f/schmasampl ... ealim.png/
Voie G/D : http://img404.imageshack.us/img404/484/ ... levoie.jpg
Voie de "ground" : http://img194.imageshack.us/content_rou ... ia=mupload

(désolé pour les schémas et les scans approximatifs
Dernière édition par Bidoux le 12 Aoû 2010 10:32, édité 1 fois.
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Annonce

Message par Google » 12 Aoû 2010 10:23

Publicite

 
Encart supprimé pour les membres HCFR

Message » 12 Aoû 2010 10:30

Hello bidoux,

il est ou ton schéma ?

Cordialement Gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 12 Aoû 2010 10:41

Wouah, bien trop rapide pour moi :o ( :mdr: ) j'ai édité mon post juste là. Ils sont un peu de travioles, je peux refaire des scans propres s'il faut.
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Message » 12 Aoû 2010 10:55

Pour l'alim j'aurais fait bien plus simple ... un 7812 pour commencer .
A quoi servent les diodes de partout (sauf pour la zener (là je vois).)
En général on mets desdiodes pour protéger les régulateurs, mais pas vraiment comme tu les as mises.
regarde la doc des LM : http://www.datasheetcatalog.org/datashe ... 9144_1.pdf

Mais bon il faut dire que j'ai pas tout suivi les discussions avec catsiano sur ton "virtual ground".

Pour le schéma de l'ampli cela a l'air Ok, masi tu n'as mis aucune compensation/filtre - ce qui fait que tu risques des oscillations.
En général en entrée on mets un condo pour filtre les très hautes fréquences, (par exemple 1K + 47pF - regarde sur le post de mon petit ampli casque).
Et il faut aussi mettre une compensation dans la contre réaction - pour la même raison.
il ne faut pas oublier que ton AOP peut aller allègrement dans les Mhz ... alors il faut le calmer, dejà un NE5532, il vaut mieux le faire, alors pour un OPA2134, le risque est bien bien plus important.

Pour le ground virtuel, j'ai pas compris pourquoi tu faisais cela :oops: je pense que l'on peut là aussi faire plus simple, mais je ne suis pas un expert.

Cordialement Gilles.
Dernière édition par Yuli_35 le 12 Aoû 2010 11:10, édité 2 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 12 Aoû 2010 11:04

le lm317 dans ton schéma d'alim prend qu'elle fonction ?
catsiano
Contributeur HCFR
Contributeur HCFR
 
Messages: 3013
Inscription: 21 Juil 2006 20:25
  • offline

Message » 12 Aoû 2010 11:08

voilà un filtrage simpliste, c'est pas le meilleur du monde, mais ca marche sans se poser de questions transcendantales.
Image

il faut remplacer les 7815 par ce que tu souhaites (7812), et ajouter en amont des régulateurs des condos de 2.2-4.7mF (enfin comme tu veux)
tu peux appliquer le même principe avec les LM337/317. C'est un poil plus compliqué (plus de composants, mais cela se fait bien aussi).

voilà mes 2 cents.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 12 Aoû 2010 11:09

En fait, ce que je n'ai pas indiqué, c'est que l'ampli est censé être piloté par une pile 9V. Le LM317 et la Zener servent à la recharger. La toute première diode est une protection, si je branche une alim alternatif ou une continue à l'envers, ça ne fait pas trop perdre de tension et c'est toujours rassurant. A ce moment là j'aurais peut-être pu en enlever une autre mais je fais évoluer l'ampli selon les problèmes que je rencontre, ce qui fait que tout n'est pas cohérent.

Une très grande partie de l'alimentation est copiée ici (http://www.amb.org/audio/mini3/mini3_sch.png), c'est une base fiable normalement

Toute l'histoire de masse virtuelle vient du fait que j'utilise justement une pile 9V, qui ne peut pas facilement donner d'alimentation symétrique. Donc soit on fait un truc avec une alimentation unique et on mets des condensateurs à l'entrée et à la sortie ( ce que j'envisage pour un prochain projet) soit on fait une masse artificielle.
On pourrait aussi utiliser un module à découpage pour diviser la tension de la pile ou bien tout simplement deux piles (comme dans le Rx de Alo) mais ça devient compliqué.

Je vais certainement mettre des compensations à l'entrée et sur la résistance de feedback pour aider à la stabilité.

Catsiano, le LM317 est une source de courant qui sert à charger une batterie. Ici AMB a rajouté une zener pour avoir une tension même sans batterie de 9V. Ca fait un régulateur un peu étrange avec deux sources de tensions en parallèle, j'imagine que les deux didoes en sorties sont là pour éviter que l'un marche sur l'autre.
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Message » 12 Aoû 2010 11:15

Ok .... En clair .. le LM7812/LM317 ne servent a rien si tu es sur batteries.
Pour le Virtual ground ... mouai ... moi j'aurais mis 2 batterie/piles. 8-) C'est plus simple (j'aime bien les choses simple 8-) )
En plus quand on est sur piles on essaie de réduire au maximum la consomation, or ici il faut alimenter un AOP pour créer ton 0V . C'est pas monstrueux, mais on bouffe de l'énergie.

En tout cas ton truc doit fonctionner.

As tu bien +4.5 et -4.5V entre le Virtual ground et le V+/V- ?
et qu'est-ce qui ne fonctionne pas ?

Gilles.
Dernière édition par Yuli_35 le 12 Aoû 2010 11:29, édité 1 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 12 Aoû 2010 11:26

Mettre deux batteries ça pourrait être pas mal, le truc c'est que ça serait mieux de faire un système "intelligent" à ce moment là, avec un µcontrolleur qui regarde l'état des batteries, les recharges et contrôle la température. Sinon le risque c'est d'avoir des batteries qui se déchargent de manière asymétrique. Après c'est dur à implanter de manière DIY, et ça n'est pas forcément la solution de facilité. Le plus simple est de faire un diviseur de tension symétrique avec des résistances mais là, niveau courant on a quelques mA, pas plus.

J'ai bien les tensions qu'il faut (plutôt +et- 5.5V vu que je fonctionne uniquement sur secteur). En fait, l'ampli marche presque, sauf qu'il sature à fort volume et sur les grosse charges (je lui ai mis mon DT880) il ne marche plus du tout et fait un bruit de fond très important. Il y a aussi un bruit de fond en général qui est trop fort pour ce que devrait donner un ampli casque.

L'autre truc c'est l'offset (-500mV environ) qui apparaît lorsque je branche une charge à la sortie et une source à l'entrée...
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Message » 12 Aoû 2010 11:27

Bidoux,

A l'étage de sortie, les 4.7R de collecteurs ne devraient pas plutôt être en émetteurs ?
JM Plantefeve
 
Messages: 170
Inscription: 08 Aoû 2009 10:52
Localisation: Nord - France

Message » 12 Aoû 2010 11:33

JM Plantefeve a écrit:Bidoux,

A l'étage de sortie, les 4.7R de collecteurs ne devraient pas plutôt être en émetteurs ?

Oups ... effectivement.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 12 Aoû 2010 11:34

C'est l'astuce de ce montage, catsiano utilise les mêmes caractéristiques de jonction base-émetteur pour la polarisation que pour le push-pull. Comme elles sont couplés thermiquement (les pointillés rouges), on n'a plus besoin des résistances d'émetteur.
Il faut voir les 4.7ohm comme des protections de courant. (j'ai mis moins de 10ohm, j'avais un peu peur d'être trop limité)
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Message » 12 Aoû 2010 11:52

bidoux
oui il utilise le courant de la patte ajustable pour charger une batterie

le temps qu'elle charge c'est le régulateur 12V qui conduit et alimente
si tu enlève la pile c'est le lm317 qui alimente en courant puisque il sort une tension
de 13,2 V le regulateur 12V ne conduit pratiquement plus rien
catsiano
Contributeur HCFR
Contributeur HCFR
 
Messages: 3013
Inscription: 21 Juil 2006 20:25
  • offline

Message » 12 Aoû 2010 11:55

Je ne te suis pas, lorsque l'alim n'est pas chargée (interrupteur ouvert) j'ai 12V aux bornes de la zener et 11.88 à la sortie du 7812, donc les deux sont à peu près au même niveau de tension pour la sortie. Si seulement le 317 conduit lorsqu'il n'y a pas de batterie et que le 7812 ne fait rien, j'ai un courant max de 15mA, c'est un peu juste !
Bidoux
 
Messages: 500
Inscription: 29 Déc 2008 22:10
  • offline

Message » 12 Aoû 2010 12:01

c'est 12V + la tension de reference 1,2V ( tension qu'on va retrouver sur la resistance de 82 ohm )
catsiano
Contributeur HCFR
Contributeur HCFR
 
Messages: 3013
Inscription: 21 Juil 2006 20:25
  • offline


Retourner vers Amplis et Préamplis