Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 6 invités

Radio wifi amplifiée sur batterie

Message » 08 Aoû 2010 11:34

c'est en effet une petite etude à faire. La première erreur serait de prendre une zener de 12V.... le comparateur ne fonctionnerait jamais.
L'idée est de prendre par exemple une 6,8V pour E+ et de faire un diviseur de tension avec des résistances fixe et une variable sur E- et regler cette varistance au moment ou les batteries arrivent à 11,98V

trouve LTspice IV sur la toile, il est gratuit. Et trouve un tuto en PDF, qui est facile à trouver

essaye ce soft qui permet de simuler des circuits
ainsi que le tuto
Optoma HD50, Pioneer BDP-LX58, Toshiba HD-XE1, Marantz SR5003, Denon SACD 5.1 HDMI, Acoustic Energy aegis 6.0 + Sub DIY JMlab 38wx.
Marantz SC80 + 2 SM80, Denon DCD 2010ae, Seas Coax Mag18 DIY, filtre actif DIY.
Mini salle dediée, sonde HCFR, Harmony 1000
Willou
 
Messages: 5454
Inscription: 13 Aoû 2003 10:18
Localisation: Banlieue Parisienne (Yvelines)

Annonce

Message par Google » 08 Aoû 2010 11:34

Publicite

 
Encart supprimé pour les membres HCFR

Message » 08 Aoû 2010 12:32

tu vas faire de moi un electronicien! je regarde tout ça.
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 16 Aoû 2010 17:28

livraison samedi, un dimanche pluvieux : toutes les conditions réunies pour faire avancer le projet :wink:
j'ai donc monté le circuit du régulateur sur une plaque d'essai à bandes. Une première pour moi.
Image

Dabord, merci willou de m'avoir fait mettre un fusible. Dans les manips de cablages j'ai réussi a faire un court circuit et le fusible a joué son rôle. ouf.

Ca fonctionne, bien que le régulateur sorte 5,05V a vide et au mieux 4,6V en charge (350mA)... et ça baisse avec la décharge de la batterie. Pas terrible : je pensais que ce serait mieux régulé. Le musicpal s'en satisfait, donc pas grave.

les soucis :
1. gros souci de bruit parasite. J'ai cru que c'était dû au régulateur, seul composant nouveau introduit. Après avoir bien cherché, c'était dû au long cable signal RCA utilisé pour le test. Avec un plus court, le bruit est toujours là, mais n'est plus gênant. Dans le montage final, le lien sera encore plus court et ça devrait aller. Le cable faisait peut être une boucle de masse trop longue ?

2. plus gênant : en branchant le régulateur sur les deux batteries en série (12V), l'ampli a des ratés. Je ne peux écouter qu'a 35-40%. Et le 7805 chauffe un max.
Avec le régulateur alimenté par une seule batterie (6V) tout va bien: l'ampli monte jusqu'à 60% et accessoirement, le 7805 ne chauffe presque pas.
Dans cette configuration, une batterie se décharge plus vite que l'autre. test en cours pour vérifier l'autonomie. Et quid de la recharge ?
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 16 Aoû 2010 17:29

Que se passe t il dans ce montage lors de la recharge ?
R1 symbolise l'ampli et R2 le musicpal
Image
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 16 Aoû 2010 19:29

1)es ce que toutes tes masses sont relié ensemble ?
pas exemple, pour mon filtre actif, j'avais oublié de connecter les masses des RCA au reste du montage. J'avais du bruit à partir d'1/3 du volume de l'ampli

2)je pense que ton ampli tire trop de courant, le régulateur n'en à pas assez pour fonctionner, la tention chute, le musicpal n'en n'a plus assez pour fonctionner à son tour

autre explication : ton musicpal tire plus que les 350mA que tu as relevé, d'où une perte de tension aussi important (0,55V). D'où la chauffe importante

Avec 2 alimentaitons indépendante, ton système fonctionne bien ?

peut être des retours de courant dû à l'ampli... il faudrait peut essayé avec des diode de boucle

3)pour le montage. je pense (encore) que ton système va se décharger plus vite et la recharge va être plus longue également.

désolé de ne pas pouvoir t'aider plus
Optoma HD50, Pioneer BDP-LX58, Toshiba HD-XE1, Marantz SR5003, Denon SACD 5.1 HDMI, Acoustic Energy aegis 6.0 + Sub DIY JMlab 38wx.
Marantz SC80 + 2 SM80, Denon DCD 2010ae, Seas Coax Mag18 DIY, filtre actif DIY.
Mini salle dediée, sonde HCFR, Harmony 1000
Willou
 
Messages: 5454
Inscription: 13 Aoû 2003 10:18
Localisation: Banlieue Parisienne (Yvelines)

Message » 17 Aoû 2010 0:40

oui toutes les masses sont reliées partout au négatif de l'alimentation. J'ai tout vérifié au multimètre, et fait tous les tests croisés possibles. Avec des alims indépendantes tout est nickel. Ca n'apparait qu'en branchant sur la même batterie avec le régulateur. Mais bon, ca va déjà bien et je pense qu'en montant proprement avec des fils courts, ça ira.

Quand le régulateur est alimenté en 12V, l'ampli coupe comme s'il manquait de courant par moments. Ca n'arrive pas quand le régulateur est alimenté par une seule batterie.
La consommation du musicpal est facile à mesurer, c'est du continu. Pour l'ampli, c'est sur qu'il tire des pointes de courant importantes difficiles à mesurer.
La seule différence entre régulateur alimenté en 12 ou 6V, c'est l'energie perdue dans le régulateur. Ca doit venir de là.

Le test d'autonomie a fini après 8 heures (au lieu de 27H avec l'ampli seul !). Au départ, les deux batteries délivraient 6,4V. La batterie qui alimente le musicpal a fini à 5,58V et l'autre à 6,34V.
A 5.58V, le régulateur délivrait encore 3.9V et le musicpal fonctionnait toujours! C'est l'ampli qui manque de courant et se met en protection.

Laisser descendre jusqu'à 5,6V m'inquiètait, mais j'ai lu quelque part que les batteries au plomb supportaient bien la décharge. Ma crainte c'est que la recharge se passe mal, vu que les deux batteries sont dans un état de décharge très différent.
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 17 Aoû 2010 0:41

Willou a écrit:désolé de ne pas pouvoir t'aider plus

tu m'aides énormément :D
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 17 Aoû 2010 12:08

je ne crois pas qu'il faille s'inquieter pour la recharge des batteries. Une fois que la première est pleine, le courant de charge se dirigera vers l'autre. Le seul hic, le temps de charge sera beaucoup plus long

Comme je m'en doutait, le système tient moins longtemps de la config "12V pour ampli et 6 pour Musicpal"

en 12V pour le régulateur, branché sur le secteur, tu as les mêmes problèmes ?

en simulant tes batteries avec l'alim de labo en 12V, aussi ?
Optoma HD50, Pioneer BDP-LX58, Toshiba HD-XE1, Marantz SR5003, Denon SACD 5.1 HDMI, Acoustic Energy aegis 6.0 + Sub DIY JMlab 38wx.
Marantz SC80 + 2 SM80, Denon DCD 2010ae, Seas Coax Mag18 DIY, filtre actif DIY.
Mini salle dediée, sonde HCFR, Harmony 1000
Willou
 
Messages: 5454
Inscription: 13 Aoû 2003 10:18
Localisation: Banlieue Parisienne (Yvelines)

Message » 17 Aoû 2010 14:23

ou t'avais bien anticipé.
Willou a écrit:Une fois que la première est pleine, le courant de charge se dirigera vers l'autre. Le seul hic, le temps de charge sera beaucoup plus long
je te confirme pour la durée de charge... toute la nuit et c'est pas fini. C'est plutôt rassurant ce que tu dis sur la recharge, j'avais peur que la première batterie souffre de surcharge en attendant que la seconde soit pleine. Et aussi peur que le chargeur 12V "intelligent" s'égare car il est censé s'adapter à l'état de décharge de la batterie.

en simulant tes batteries avec l'alim de labo en 12V, aussi ?
me rappelle pas si j'ai testé ça... j'ai refait tous les tests en notant cette fois!

Code: Tout sélectionner
ampli        régulateur          musicpal                résultat
bat 12V       bat 12V           régulateur (4.41V)      crachottements
bat 12V       bat 6V            régulateur (4.32V)      OK
bat 12V       alim 6V           régulateur (4.43V)      OK
bat 12V        -                alim 5V                 OK
alim 12V      bat 6V            régulateur (4.41V)      OK
alim 12V      bat 12V           régulateur (4.6V)       OK
alim 12V      alim 12V          régulateur (4.41V)      crachottements

Dès que l'ampli et le régulateur sont alimentés par la même alim 12V, ça va pas. Le musicpal génère des crachotements. 7805 défectueux ? C2 en filtrage est insuffisant ? la batterie A pollue le régulateur ?
le cablage pour la deuxième ligne est le suivant. j'ai raté quelque chose ?
Image

Mon alim de labo est une très vieille diy, un plan elektor. Le vu mètre analogique va jusqu'à 3A mais je me rappelle pas combien elle peut délivrer. Quand je monte le son vers 75%, il y a des pointes au-delà de 1,5A et l'ampli coupe. Finalement, batteries ou alim labo ne change rien pour la puissance disponible.
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 18 Aoû 2010 13:52

la recharge des batteries ne se passe pas bien. Après plus de 18H en charge, la deuxième batterie n'était toujours pas chargée. J'ai du la recharger seule. Heureusement, mon chargeur permet de charger différentes tensions 2-6-12V.
Je pense que le chargeur est perturbé lorsqu'une batterie est nettement plus déchargée que l'autre. S'il faut >18H pour recharger, c'est rédhibitoire. J'abandonne l'idée d'alimenter le musicpal avec une seule batterie.

J'ai continué d'écumer le web et trouvé des infos sur le 7805 : il lui faut au moins 2V de plus entre l'entrée et la sortie pour réguler correctement. Ce qui n'est pas clairement indiqué dans les datasheets.grrr! Sur la batterie de 6V, ça pouvait pas le faire. Mais c'est pas normal qu'il sorte seulement 4,41V alimenté en 12V. Il semble aussi qu'il génère beaucoup de perturbations hf avec la montée en température.
En cherchant des régulateurs low-drop, je suis tombé sur le LM2940-CT5, fait pour l'automobile où le 12V règne.
Vu le prix, ca mérite un deuxième essai avec ce régulateur et les capacités qui vont bien.
C'est reparti pour un tour :mdr:
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 18 Aoû 2010 15:54

Salut,

Un 7805 ça régule bien mieux que ça d'habitude, le tien doit avoir un soucis. Par habitude, il faut au moins 3v au 7805 pour travailler dans de bonnes conditions.

D'après ton dessin, je dirais que si tu n'as qu'un petit condo plastique en entrée avec de longs fils vers la batterie, il est possible que ce ne soit pas suffisant. Essaies de rajouter un petit 100uF en entrée.

Pour alimenter ton petit montage sur les deux batteries en série, l'idéal serait un régulateur a découpage qui te permettra de ne pratiquement pas perdre d'énergie sous forme de chaleur. LM2576 par exemple, très simple à mettre en oeuvre. Il faut simplement lui rajouter une diode shottky et une petite bobine.

Concernant l'ampli qui se coupe, il faut peut être lui adjoindre un gros condo pour lisser un peu les appels de courant, surtout si le cablage est relativement long. 10.000uF en 25v c'est pas très gros.
ampli diy tda7294, peerless sputnik 14-2, preamp kaneda, dac tda1541, ampli 8W le monstre, clone audionote az3, philips cd723 édition spéciale FB 21th anniversary, platine DIY en cours
apolon34
 
Messages: 2176
Inscription: 24 Mar 2003 15:57
Localisation: Rouen (76)

Message » 18 Aoû 2010 17:53

apolon34 a écrit:Salut,

Un 7805 ça régule bien mieux que ça d'habitude, le tien doit avoir un soucis. Par habitude, il faut au moins 3v au 7805 pour travailler dans de bonnes conditions.

D'après ton dessin, je dirais que si tu n'as qu'un petit condo plastique en entrée avec de longs fils vers la batterie, il est possible que ce ne soit pas suffisant. Essaies de rajouter un petit 100uF en entrée.

Pour alimenter ton petit montage sur les deux batteries en série, l'idéal serait un régulateur a découpage qui te permettra de ne pratiquement pas perdre d'énergie sous forme de chaleur. LM2576 par exemple, très simple à mettre en oeuvre. Il faut simplement lui rajouter une diode shottky et une petite bobine.

Concernant l'ampli qui se coupe, il faut peut être lui adjoindre un gros condo pour lisser un peu les appels de courant, surtout si le cablage est relativement long. 10.000uF en 25v c'est pas très gros.

chouette, on est trois maintenant :mdr:
- en entrée, sur le 7805 il y a 1000µF. il est dessiné petit, mais il est assez gros non ? c'est plutot en sortie qu'il est petit (10nF) par rapport aux valeurs que je vois en surfant. Mais il y a tellement de valeurs différentes sur les schémas que je vois, que je sais plus. Pour le LM2940 je vais m'en tenir à la datasheet fabriquant!

- Ajouter un condensateur pour l'alim de l'ampli: j'y avais pensé aussi mais pas testé. L'ampli a déjà 4700µF sur la carte. J'ai des 15.000µF/40V qui trainent. J'essaierai. Mais c'est pas le plus genant : du moment que ca tient à 60% du volume comme maintenant, c'est bon. le plus grave sont ces bruits parasites qui viennent du régulateur probablement.

- Régulateur a découpage : oui c'est une idée que j'ai vue en parcourant le web. C'est le nb de pattes et de composants additionnels qui m'ont effrayé :mdr:
J'avais l'impression que c'était un niveau de complexité supérieur mais vu le prix, je peux tenter plusieurs approches du problème et retenir celle qui marchera le mieux.
J'ai creusé la question un peu plus avant : vu le faible besoin de courant (<0,5A), un LM2575 suffira. C'est vai que alimenté en 12V, et si je mé_pas_gouré, il dissiperait moins de 0,5W ! pas besoin de radiateur du tout. chouette.

Une datasheet du LM2575 donne le schéma suivant :

Image

Chez selectronic, on trouve une "shotky" équivalente 1N5818.
Vu les valeurs, les condos seront chimiques tous les deux.
Trouve pas quelle inductance 330µH prendre: il y a bien 180µH au rayon anti-parasites de selectronic, mais aucune info dans la datasheet sur l'impact de cette inductance! grrr! Une 180µF ça le ferait ? sinon, je peux acheter celle là et rajouter des spires par moi même ?
J'ai aussi un paquet de MUR860. Ca remplacerait la shotky ?
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux

Message » 18 Aoû 2010 20:45

Salut,

Pour le 7805, je lui mettrais un petit 100uF en sortie. Je n'ai rien trouvé dans la datasheet concernant le mini mais ça peut pas faire de mal.

Pour la diode, 1N5818 c'est ok. il suffit qu'elle encaisse la tension d'entrée de ton régul (12v) et un courant d'environ 1A.
Pour la self, prends la 10.6500-6 de chez selectronic. Elle encaisse 0.71A, ca devrait le faire sans soucis.

J'en arrive aux memes conclusions que toi, moins de 0.5W contre 2.5 environ pour un 7805. La dissipation que tu économises te permet de gagner ça en autonomie.

Concernant les batteries, il faut que tu décharges les deux simultanément si tu n'as pas un chargeur pour chacune, sinon tu auras des soucis a la recharge (ce que tu as déjà observé :mdr: )

En tout cas j'aime bien ton projet, c'est vraiment super sympa !
ampli diy tda7294, peerless sputnik 14-2, preamp kaneda, dac tda1541, ampli 8W le monstre, clone audionote az3, philips cd723 édition spéciale FB 21th anniversary, platine DIY en cours
apolon34
 
Messages: 2176
Inscription: 24 Mar 2003 15:57
Localisation: Rouen (76)

Message » 18 Aoû 2010 20:49

Concernant la mur, ça fonctionnera mais au détriment du rendement. Elle a une une tension de seuil dans les deux a trois fois plus élevée.
ampli diy tda7294, peerless sputnik 14-2, preamp kaneda, dac tda1541, ampli 8W le monstre, clone audionote az3, philips cd723 édition spéciale FB 21th anniversary, platine DIY en cours
apolon34
 
Messages: 2176
Inscription: 24 Mar 2003 15:57
Localisation: Rouen (76)

Message » 18 Aoû 2010 21:35

merci. mouais, les batteries ça a l'air cool comme ça, mais on fait pas ce qu'on veut finalement.

470µH au lieu de 330... Sur la photo, ça à l'air facile: je débobinerai pour aller au bout du bout :wink: et puis de toutes manière faut que je m'entraine à débobiner car Agno m'embête avec ses valeurs de selfs pas normalisées dans un filtre d'enceinte (projet parallèle) :mdr:

je vais insister sur le 7805 : y pas de raison. je veux en avoir le coeur net. J'en achète un autre et le remplacerai sur ma carte, avec une capa plus élevée en sortie et on verra.

J'apprends des tas de trucs sur ce projet :D merci de m'aider. Je commande les composants ce soir ou demain. Vivement le test comparé des alims régulées :)
Le principe de la régulation a découpage me plait bien : c'est élégant, je gagne en chaleur et la place du radiateur. Ca m'arrange car je sens que je vais être à l'étroit dans la boite.
La suite dans quelques jours.
audiophile : personne qui achète de la musique pour écouter son matériel au lieu de faire l'inverse!
alkasar
Contributeur HCFR
Contributeur HCFR
 
Messages: 11345
Inscription: 29 Nov 2005 22:47
Localisation: Neuf deux



Retourner vers Amplis et Préamplis

 
  • Articles en relation
    Dernier message