Modérateurs: Staff Home-Cinéma, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités

Tout ce qui concerne les logiciels lié au HC sur ordinateur (PC, Mac, Linux...)
Règles du forum
Avant de poster, merci de prendre connaissance des règles du forum : à lire avant de poster

Avis aux possesseurs d'1 carte son avec chipset VIA Envy 24

Message » 03 Jan 2007 19:34

Bon en attendant les conseils de maître Mork sur les valeurs à modifier dans les .ini (comme débrider la SE-150 et bénificier d'une sortie en 192 kHz, qui ne me sers à rien ! - mais pour le plaisir) je suis en train d'éplucher plus sérieusement la documentation de l'Envy24HT :

- horloges supportées 49,152 MHz (/256 = 192 kHz) / 24,576 MHz (/512 = 48 kHz, /256 = 96 kHz) et/ou 22,579 MHz (/512 = 44,1 kHz)
- le système fonctionne avec une seule horloge maître, de ce fait tous les flux utilisés doivent être à la même fréquence (d'où également certaines limitations lorsque la sortie/entrée S/PDIF sont actives)
- à suivre (p40 sur 68)
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Annonce

Message par Google » 03 Jan 2007 19:34

Publicite

 
Encart supprimé pour les membres HCFR

Message » 03 Jan 2007 20:59

héhé c'est bien ca ! nous allons devenir savants avec tout ca :wink:
Dommage que je ne sois pas capable de développer des drivers parce que là ca me démange !

Bon sinon en regardant aussi de plus près chez VIA j'ai trouvé une mauvaise nouvelle de plus :
An important note about support

VIA recommends that you use the drivers supplied by the manufacturer of the motherboard, card or device instead of the VIA Envy24 Family driver pack available on VIA Arena, since the drivers provided by the manufacturer of the hardware are tailored for their particular implementation of the VIA audio controller. In fact, some of the feaures of the audio controller, most notibly the QSound section, may not function at all with some cards.

VIA does not supply drivers for sound cards based on the VIA Envy24 or Envy24 HT audio controllers. Drivers for those sound cards must be obtained from the manufacturer of the sound card. The VIA Corporate web site includes a list of Envy24 and Envy24 HT sound card manufacturers here.


Donc en gros les seuls drivers avec lesquels on peut espérer une amélioration sont ceux des constructeurs, et comme pas mal d'entre eux utilisent les drivers VIA quasiment brut de fonderie et ne développent rien, nous sommes mal barrés...

Je vais essayé de contacter Onkyo pour voir si je peux obtenir quelque chose de plus mais je n'y crois pas trop, enfin comme on dit : l'espoir fait vivre ! :D
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 03 Jan 2007 23:27

Pour les pilotes : bien que le site de VIA indique le contraire comme tu viens de le préciser, ceux-ci fonctionnent néanmoins très bien avec la carte Onkyo, et n'enlèvent rigoureusement aucune option. Pour les cartes Audiotrak évidemment c'est une autre histoire... :roll:

D'ailleurs, curieusement, le kernel streaming fonctionne impéccablement depuis que j'ai dû complètement réinstaller la carte, bien qu'étant passé d'abord par la version 5.00b, et en faisant un downgrade comme un cochon vers la 4.51c... :o Miracle... une IRQ Windows a dû bouger probablement...

Image
Sinon voilà un schéma de principe un peu plus lisible de l'Envy24HT

Image
Et les routages possibles des flux audio S/PDIF... s'ils ont été implementés par le constructeur bien sûr ! À lire le graphe récupérer l'entrée S/PDIF en AC3 5.1 paraît improbable... :(
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 04 Jan 2007 10:45

Oui c'est bizarre d'autant que les différences entre driver onkyo et VIA sont minimes : le japonais en plus et quelques clefs de registre qui changent et puis c'est tout...

Sinon autre mauvaise nouvelle qui corrobore ce que tu disais plus haut :
J'ai demandé à Schrek d'essayer les drivers VIA avec ca carte et ca n'a pas amélioré les choses par rapport à la sortie numérique, toujours bridée en stéréo.
Du coup il a flashé sa carte avec le firmware de l'onkyo et pris les drivers VIA, et là, miracle, la sortie fonctionne normalement !

Il semble donc que la sortie soit bridée non pas par le driver audiotrack, mais par le firmware !
Donc pour l'entrée numérique de l'onkyo il y a fort à parier que se soit la même chose...
Ou alors, les drivers sont tellement mauvais qu'ils n'exploitent pas correctement les différents firmwares.

PS : tu utilises quels drivers maintenant, les 4.51c ? si le pb vient juste d'une IRQ, c'est facile à changer ca :wink:

EDIT : je n'avais pas lu la fin de ton post :
En fait théoriquement, récupérer un signal numérique stéréo ou 5.1 ne doit pas changer grand chose du point de vue du chipset, vu qu'on ne lui demande pas de faire de conversion mais juste d'acheminer le signal là ou l'on veux.
La conversion se fait ensuite de manière logicielle (comme avec un lecteur dvd ide).

D'ailleurs pour exemple, le passtrough spdif-in => spdif-out fonctionne très bien ce qui veux donc bien dire que ca marche quand ils le veulent.
Reste à savoir si c'est la partie driver ou l'eeprom qui bride ce signal, et j'ai comme l'impression qu'il y a un peu des 2...
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 04 Jan 2007 16:50

Pas le firmware, l'EEPROM ! J'insiste parce que ce n'est pas tout à fait pareil... Un firmware c'est un code avec des instructions, une EEPROM c'est uniquement des informations de câblage.

J'ai oublié de le mentionner, mais les informations de l'EEPROM conditionnent la manière dont les pilotes intéragissent avec le processeur audio, en lui indiquant les câblages présents/absents. Malheureusement, je peux t'envoyer le dictionnaire VIA, mais je ne m'y connais pas assez pour en tirer quoique ce soit.

Oui, on le lit sur le graphe : de S/PDIF In vers Out routage possible en passthrough 5.1, mais dès l'instant ou tu sors de cette route, les annotations L/R me font penser que seuls des signaux stereo PCM peuvent être gérés... enfin c'est plus une interrogation qu'une affirmation...

Sinon pour les pilotes je suis demeuré en 4.51c du coup, tant que ça marche :)
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 04 Jan 2007 17:31

Désolé pour cette faute de langue :oops:

Sinon envoi moi toujours le dictionnaire, je regarderai ca, on ne sait jamais.
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 04 Jan 2007 20:22

Le dictionnaire est parti...

Sinon un autre truc que j'ai oublié de citer : (fil d'origine http://forums.viaarena.com/messageview. ... erthread=y )
I've been looking at the source code of the Linux devicedriverfor the ICE1724 chips, and I've figured out what some of the EEPROM bytes actually are controlling. Hopefully this will be of some use to EEPROM hackers:

Bytes 0-3: PCI subsystem vendor and subsystem device ID (Thisiswhat allows the driver to detect the brand/model of the card -the main PCI vendor and device ID are fixed and identify the card as an ICE1724 device.)

Byte 4: Size of EEPROM data

Byte 5: EEPROM version (seems to be supposed to be1 for ICE1712 (Envy24) and 2 forICE1724 (Envy24HT), but seems like it's usually set to 1even on Envy24HT..)

Byte 6: System configuration byte - gets written to the corresponding card register by the driver. Controls clock crystal configuration, MPU-401 MIDI UART, how many ADCs/DACs are connected.

Byte 7: ACLink configuration byte - gets written to the corresponding card register by the driver. Controls the connection to the AC97 codec (i.e. the VT1616 used for the front, rear, center/LFE outputs).

Byte 8: I2S configuration byte - gets written to the corresponding card register by the driver. Controls the connection to the I2S codec (i.e. presumably the Wolfson codec for the high sample rate output).

Byte 9: SPDIF configuration byte - gets written tothecorresponding card register by the driver. Controls the SPDIF transmitter.

Byte 10: GPIO Direction

Byte 11: GPIO Direction 1

Byte 12: GPIO Direction 2

Byte 13: GPIO Mask

Byte 14: GPIO Mask 1

Byte 15: GPIO Mask 2

Byte 16: GPIO State

Byte 17: GPIO State 1

Byte 18: GPIO State 2

The GPIO registers seem to be written into registers on thecard by the driver as well, these control the GPIO outputs which are presumably used to set sample rates on the DACs, etc.

From this I can conclude:

-Bytes 0-3 should not be modified from what came on the card,unless you want to change it to be recognized as a different brand of Envy24HT card.

-Bytes 4-5 should likely not be modified either.

-Bytes 6-18 should likely not be modified from what came on the card, unless you really know what you are doing. These control the routing and settings of various signal lines which depend on how the card is physically wired. Messing with these will likely cause some of the DACs not to work (like the problems some have had with the high sample rate output after EEPROM changes).

Of the "don't change" bits of the config file thatwasposted, the ones that it seems to change from what comes ontheAV-710 are the PCI subsystem vendor/device IDs (so it will looklike a Maya card) as well as byte 1 of the SPDIFconfiguration(this seems to tell the card that it has SPDIF inputwhen itdoesn't) and some of the GPIO bytes which are swappedbetween 00 andFF (not sure what effect this has, probably nothinggood).

This means the interesting part as far as any QSound settings is likely bytes 19-31 (or as in the eeprom.ini file in hex, bytes 13-1F). The Linux driver does not use these for anything, so changing these seems unlikely to break the basic card operation. I don't know where any of these bytes may be documented however. I don't think the card itself could be making any use of them, it is purely the driver that would look at these values to control things like (possibly) enabling QSound.

Does the currently posted config file result in the high sample rate output being screwed up, or not? If not, then maybe restoring bytes 0-18 of the EEPROM to the original values on the AV-710 will allow the QSound to work without such side effects.
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 05 Jan 2007 20:24

Alors je réponds à une interrogation de Mork en suspens : concernant l'histoire d'IRQ Windows qui aurait bougée lors de la réinstallation (avec démontage physique de la carte), c'est la seule explication software que je vois au changement de comportement avec le kernel streaming...

Bonne nouvelle autrement : le S/PDIF-In avec AC3/DTS semble possible, mais je n'ai trouvé cette option que sur la M-Audio Audiophile 192 :
E/S numérique compatible avec signaux surround codés AC-3 et DTS

Le contenu de l'EEPROM est disponible : http://envy24.svobodno.com/cards/ap192/ ... 2prom.dump
Mais le câblage et les DAC sont tellement différent que je doute du succès de l'opération :(

Sinon une page bien intéressante :
http://envy24.svobodno.com/

EDIT : http://www.ntonyx.com/vac.htm cela route les flux audio entre applications, un peu comme le directwire, peut-être y-a-t'il moyen de récupérer le flux AC3 ? (logiciel payant mais une demo existe)
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 08 Jan 2007 22:17

Je n'ai pas trop de temps de dispo en ce moment :-?

J'ai quand même essayé le logiciel VAC, qui m'a l'air très bien !
Malheureusement ca ne fonctionne pas avec l'entrée s/pdif, mais bon je n'y croyais pas trop non plus...
En renvoyant le signal sur le "cable virtuel" on voit bien les barres de sons bouger, mais aucun son ne sort quand j'ouvre cette source.
Si j'essaie de le renvoyer sur autre chose il me met le message suivant : "cannot open output device..."

Sinon j'ai également essayé de modifier des paramètres de l'eeprom avec l'eeprom onkyo et les drivers 5.0b d'orgine, et c'est comme-ci je p.....s dans un violon :cry: , je ne constate absolument aucune différence, à se demander si ca sert vraiment à quelque chose ces paramètres.

Je vais tester l'eeprom et les drivers de la m-audio pour voir si j'obtiens quelque chose.

Après tout ca j'ai bien l'impression que l'unique option restante sera le développement de pilotes :roll: en gros c'est mal barré.
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 12 Jan 2007 12:59

Comme prévu l'eeprom et les drivers de la m-audio ne donnent pas de résultats plus satisfaisants (c'est même pire :lol: ).

Je vais essayer de développer un pilote qui me permettrai de faire ca, mais bon ca risque de prendre du temps, beaucoup de temps... :roll:
En attendant, j'utilise les pilotes de l'onkyo qui marchent bien mis à part sur ce point.
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 12 Jan 2007 14:27

En chinant sur les divers sites de constructeurs, j'ai trouvé sur le site coréen de Audiotrak une version 5.10b des pilotes VIA...
http://www.audiotrak.co.kr/zeroboard/vi ... c=asc&no=4

La date est plus récente que la 5.00b, mais est-ce que quelqu'un pourrait confirmer que la version des pilotes est bien supérieure à la 5.00b ?
Interrogation de ma part concernant l'absence de cette version sur le site officiel de VIA... :-?
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 12 Jan 2007 17:32

ce sont les drivers pour vista, en beta. Tu peux les trouver sur viaarena...
fabiov
 
Messages: 310
Inscription: 07 Juil 2004 18:53
Localisation: Paris 15eme
  • offline

Message » 12 Jan 2007 18:09

Oui, moi aussi j'ai lu la mention Vista sur la capture d'écran, mais en-dessous de celle-ci il est indiqué une compatibilité avec Windows 98/2000/XP... enfin je ne lis pas le Corréen couramment, mais c'est la traduction très approximative de Google :
Code: Tout sélectionner
v5.10 beta classifications: Driver date: 2006.10.27 operation setups: Window rain star and window 98SE, ME and 2000, XP and 2003 features: Automatic establishment version

Je suppose que Vista = Rain star ?
Le contenu de l'archive contient un dossier XPWDM.
Et dans le fichier setup.ini on peut lire :
[SupportOS]
Win95=1
Win98=1
WinME=1
WinNT4=1
Win2K=1

Mais tout à fait exact que sur le site de Viaarena ils ne mentionnent qu'une compatibilité Vista...
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris

Message » 12 Jan 2007 20:09

Oui ces pilotes fonctionnent également avec XP, je les ai essayé.

A priori, peu de changement visible, par contre après une rapide écoute, le son m'a paru plus mauvais donc à prendre avec des pincettes.
Mork
 
Messages: 207
Inscription: 30 Nov 2002 21:12
Localisation: 77
  • offline

Message » 12 Jan 2007 21:42

A ne pas prendre du tout alors dans mon cas... j'espérais que cette version pourrait solver l'instabilité de l'AudioDeck en version 5.00b sur mon système XP SP1 (notamment l'impossibilité de garder en mémoire certains paramètres, come le taux d'échantillonnage par défaut).
depanneur chef
 
Messages: 235
Inscription: 16 Avr 2005 22:33
Localisation: Paris



Retourner vers Logiciel PC Home-cinéma

 
  • Articles en relation
    Dernier message