Modérateurs: Staff Home-Cinéma, Staff Juridique • Utilisateurs parcourant ce forum: ticad et 14 invités

Tout ce qui concerne les logiciels lié au HC sur ordinateur (PC, Mac, Linux...)
Règles du forum
Avant de poster, merci de prendre connaissance des règles du forum : à lire avant de poster

sous-titre avec mpc ne s´affichent pas

Message » 02 Juil 2011 18:10

Bonjour,
je n´arrive pas à lire les sous-titres avec media player classic, ni les sous-titres inclus dans les mkv, ni ceux d´un fichier .srt.
Lorsque je lis un film, je peux sélectionner un sous-titre depuis Navigation->Langues des sous-titres, mais aucun sous-titre n´apparait.
Lorsque je veux charger un fichier .srt en cliquant sur Fichier->Charger des sous-titres , j´obtiens le message d´erreur suivant:

To load subbtitles you have change the video renderer type and reopen the file.
-DirectShow: VMR7/VMR9 renderless or Haali´s
-RealMedia...



Pourtant dans Affichage->options->lecture->sortie->Video DirectShow j´ai bien choisi "VMR9(sans rendu)".
Quelqu´un aurait une idée comment résoudre ce problème?

P.S.: si ca peut aider, en cliquant sur lecture->filtes, je peux voir que les filtres suivants sont actifs:
Reclock Audio Renderer
Video Renderer
AC3Filter
CoreAVC Video Decoder

A propos est-ce normal d´avoir "Video Renderer" et "CoreAVC" actifs en meme temps?
babushka
 
Messages: 2
Inscription: 02 Juil 2011 18:03
  • offline

Message » 03 Juil 2011 17:34

Bon alors, j´ai réussi à afficher les sous-titres embarqués (dans le mkv) en changeant la priorité du filtre externe DirectVobsub. Desormais le filtre est actif quand je lance la vidéo.

Mais lorsque je veux charger des sous-titres externes (fichier .srt) j´obtiens toujours le message d´erreur "To load subtitles..." (voir message précédant).
Dans Affichage->options->lecture->sortie->Video DirectShow, c´est "VMR9(sans rendu)" qui est sélectionné. Le filtre "Video Render" est actif, lorsque la vidéo est lancée.

Par contre lorsque je choisis "VMR7(sans rendu)", j´arrive bien à charger les sous-titres externes et les sous-titres s´affichent, mais pas la vidéo! A ce moment là le filtre "Video Mixing Render 7 (Renderless)" est actif.

Comment faire pour avoir la vidéo et le texte??
Je précise que je suis sous Windows 2000.
babushka
 
Messages: 2
Inscription: 02 Juil 2011 18:03
  • offline

Message » 03 Juil 2011 20:55

Change d'OS déjà ..... XP ou 7 :roll:
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline



Retourner vers Logiciel PC Home-cinéma

 
  • Articles en relation
    Dernier message