Modérateurs: Staff Home-Cinéma, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 7 invités

Tout ce qui concerne les logiciels lié au HC sur ordinateur (PC, Mac, Linux...)
Règles du forum
Avant de poster, merci de prendre connaissance des règles du forum : à lire avant de poster

Supprimer les mini saccades simplement ?

Message » 03 Jan 2014 17:07

Je crois avoir trouvé !!! Ca a l'air ok comme ça : utilisation de MPC HC avec ffdshow (install par K lite et choix lors de l'installation) + désactivation de l'aero sous Windows. J'ai vu un film hier entier sans une saccade !
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Annonce

Message par Google » 03 Jan 2014 17:07

Publicite

 
Encart supprimé pour les membres HCFR

Message » 03 Jan 2014 17:15

Merci jacquob7 :) Mais je crois que j'avais déjà testé en désactivant Aero, et de ce que je me souviens il subsistait encore de légères saccades, même si quasi pas visibles (faut voir le graphe avec Ctrl + J quand on lance un film). Bon, sur mon ancien PC j'avais désactivé Aero à la lecture d'un film, mais c'est surtout parce qu'il manquait de puissance.

Faudra que je reteste pour voir :wink:
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 03 Jan 2014 18:05

Je vais regarder ce soir et je confirmerai. Ou non... :-p
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Message » 03 Jan 2014 21:18

Oui en fait j'ai testé, et c'est bien ce qui me semblait, ça ne règle malheureusement pas totalement le problème de fond, même si ça augmente grandement la fluidité (je pense honnêtement que c'est le court laps de temps où Aero se désactive qui rééquilibre un peu le décalage, mais ce n'est pas parfait), car j'ai constaté du tearing :-?

Donc la seule solution pour l'instant, je ne sais pas si ça marche chez toi, c'est d'aller dans les options de MPC et tu vas par exemple dans Output, tu changes de Resizer et tu cliques sur "Appliquer". Ensuite tu peux remettre le Resizer qui te plait. Mais au moins ça supprime les saccades et le tearing définitivement pendant la lecture.

Mais c'est sûr que comme solution à long terme c'est moyen :lol: Je ne comprends toujours pas ce que ça peut être :( En tout cas je suis pratiquement sûr que ça provient directement de Media Player Classic. Je pense que ça doit mal se caler quand la fréquence d'affichage change.
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 04 Jan 2014 11:51

J'ai testé hier soir sur deux films (regardés avec la courbe ctrl+J... :)). Il restait bien des saccades minim en effet... j'ai changé une option et plu de saccades pendant les deux films (meme en relancant le player etc). Mais c'est seulement en rajoutant l'option D3D fullscreen dans les options output de mpchc. Il n'y à plus les menus en plein écran, mais surtout, il n'y a plus de saccades. PAR CONTRE : j'ai un léger décalage son en s/pdif (très léger retard) que je n'ai pas en sortie "normale". J'ai testé en 24p et là, plus de décalage son... Et je n'ai pas vu de saccades sur la fin de mon film (test pas assez long pour m'en assurer). Tout ça est bien complexe en tout cas...
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Message » 04 Jan 2014 14:26

Oui c'est clair :mdr:

En tout cas c'est possible pour le mode D3D Fullscreen :wink: C'est censé supprimé le tearing notamment. Mais comme tu dis, tu ne peux plus accéder au menu, c'est justement pour ça que je ne l'active jamais. Mais en temps normal je n'ai pas ni saccades, ni tearing non plus, donc je n'en voyais pas forcément l'intérêt. Bon, on peut définir des touches de raccourcis dans les options de MPC pour le mode D3D Fullscreen, mais dans le noir, à moins d'avoir un clavier d'ordi rétro-éclairé, ce n'est pas toujours pratique :lol:

Mais je pense quand même que s'il faut désactiver Aero et ensuite activer le mode D3D Fullscreen, quelque part il y a quelque chose qui alourdit la lecture. Car comme dit, chez moi quand j'ai supprimé ces saccades, c'est fluide de chez fluide et sans tearing. Je n'ai logiquement ni besoin de désactiver Aero, ni d'activer le mode D3D Fullscreen.

J'aimerais quand même bien comprendre ce que c'est :-?

Mais je pense que ce n'est pas lié à un manque de puissance à ce moment là, car les saccades sont quand même régulière. On dirait juste que certaines frames ne sont pas affichées, ce qui créé les saccades. En fait j'ai des fois l'impression que c'est la fréquence d'affichage qui a du mal à switcher, car le problème se situe pile au moment où on bascule en plein écran.

Il n'y a personne pour nous aider SVP ? :(
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 04 Jan 2014 18:23

Bon, j'ai passé mon aprèm là-dessus... Bilan : c'est le "plein écran Direct 3D" qui m'apportait un décalage audio. En le désactivant, je me retrouvais systématiquement avec des déchirements d'image (mais certes, plus de saccades...).

Après un moment à trifouiller, j'ai décidé de changer carrément de sortie vidéo (option "Lecteur/Sortie/Vidéos DirectShow") et j'ai pris madVR (disponible directement dans l'installation du pack K-lite full, dernière version). Bilan : plus de décalage son car plus de "plein écran Direct 3D" à activer, une image sans saccade ET SURTOUT sans déchirement !!!! Et, cerise sur le gâteau, les menus sont actifs et une barre de navigation en mode plein écran permet de naviguer le long du film.

Je crois avoir trouvé une solution pour ma configuration. A vérifier à l'usage. Ca a été relou quand même...

A noter : au cours des manips, j'ai viré tous les filtres LAV pour mettre audio et vidéo en ffdshow (LAV vidéo et intel graphics semblent pas faire bon ménage du tout ; dans le doute, j'ai viré tous les codecs LAV :)).
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Message » 04 Jan 2014 18:29

Merci pour l'info :D Je regarderai aussi de mon côté un de ces 4 si j'ai le temps pour voir si je peux arranger ça d'une autre manière :wink:
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 04 Jan 2014 22:28

Bon, j'ai refait des tests et touché à quelques options dans les filtres qui sont utilisés, mais pas de changement :( Par contre j'ai bien regardé le Display Stats quand je lance une vidéo et que ça saccade. La courbe rouge a l'air quasi parfaite, tandis que la verte est plutôt éloignée et complétement tordue :lol:

Je ne sais malheureusement pas trop ce que veulent dire ces courbes, à part que quand c'est bon elle sont logiquement presque confondues et proches de la ligne bleue du milieu.

Faudrait que quelqu'un nous en apprenne plus à ce sujet, mais visiblement personne n'a trop envie de nous donner un coup de main :grr:

Mais par déduction, je dirais que la courbe rouge représente la frame qui est censée être affichée, donc déjà là faut que ce soit bien synchro avec la ligne bleu du milieu, et ensuite la courbe verte représente peut-être la frame suivante qui est pour l'instant en mémoire.

Donc si cette logique est bonne, la frame qui est censée être affichée maintenant ça va, mais pas celle qui doit suivre et qui est pour l'instant en mémoire. Donc peut-être un problème de RAM, je ne sais pas :o

Toi tu as combien de mémoire vive par exemple ? Perso j'ai 4 Go, mais ça devrait suffire logiquement. En tout cas quand il n'y a pas ce décalage ça suit parfaitement. En fait pour l'instant le problème me fait un peu penser à un sprinter qui aurait raté le départ. Ce n'est peut-être que ça finalement :mdr:

Reste à trouver comment régler le problème :-?
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 04 Jan 2014 22:55

J'ai constaté quelque chose d'assez surprenant :lol:

Quand tu lances ta vidéo en plein écran et que tu as des saccades, t'as déjà sûrement pu constaté que les saccades restent quand tu sors du mode plein écran. Ben chose bizarre, quand t'es sorti du mode plein écran et que tu mets la fenêtre de MPC en réduction et que tu l'agrandis à nouveau tout de suite après les saccades ont directement disparu :o

Va comprendre :mdr: Mais c'est vrai. En fait je voulais à ce moment vérifier dans le panneau de configuration de ma carte graphique s'il n'y avait pas un soucis de fréquence. Mais juste en réduisant la fenêtre de MPC ça règle le problème :hein:

J'ai aussi testé avec LAV Vidéo, le problème de saccade est effectivement pareil qu'avec FFDShow Video.
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 05 Jan 2014 16:22

Déception hier soir : pendant le film, 3 "sauts de puce". J'appelle "saut de puce" ce moment ou ça fait une avance d'une image, genre pour se recaler. C'est très discret, faut l'œil pour le constater. Comme j'avais du monde, je n'ai pu regarder les stats pour savoir si des frames avaient été sautées. Je reteste dans les mêmes conditions ce soir, mais en 24p, pour voir.

Je n'ai plus de décalage son avec madVR par contre ; ça, c'est sûr !

Pour les courbes, sais pas non plus. L'autre jour, j'ai remarqué que sur la longueur du film, les courbes restaient bien parallèles mais la verte s'éloignait petit à petit de la rouge ! au point qu'à la fin, elle sortait de la fenêtre en haut ! :lol:

Pour ma RAM, 4Go aussi. J'ai un core i7.
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Message » 05 Jan 2014 16:33

Pareil Core i7, donc ça devrait aller quoi :lol:

Moi perso ça va. J'ai regardé Terminator 4 hier soir et pas de ralentissement. Bon, c'est chiant de devoir réduire la fenêtre et la ragrandir après avoir basculé en mode plein écran, mais bon, c'est moins chiant que de devoir aller dans les options. Moi par contre je suis toujours en 23 ou 24 Hz pour les films. J'utilise la fonction Fullscreen et Autochange pour que la fréquence d'affichage s'adapte à chaque vidéo.

Mais je me demande si le problème n'est pas MPC lui-même. Il doit y avoir un truc tout bête qui cloche. Parce que sinon, pourquoi il suffit juste de mettre la fenêtre en réduction pour que ça redevienne fluide ? C'est trop bizarre :hein:
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 05 Jan 2014 16:37

Et ça redevient fluide pour tout le reste du film avec ta manip ???
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline

Message » 05 Jan 2014 16:46

Oui, tout à fait :D
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 05 Jan 2014 18:31

Bon, là c'est terrible !!! J'explique : je voulais tester ta manip donc j'ai réinstallé mpc hc x64 1.7.1 (dernière version ; codecs LAV en interne). Je lance un mkv et je m'attends à avoir les saccades habituelles. Et là, rien. Je me dis : "il doit y avoir un lien avec les codecs k-lite". Je désinstalle alors k-lite... Je relance une vidéo. Toujours pas de saccades... Je me dis "ok....." Je mate un peu : pas de saccade mais exactement les mêmes symptômes que d habitude : déchirement d'image et, si je veux une image parfaite, je dois mettre le plein écran D3D (mais qui provoque un décalage du son...).
Presque avoué vaincu, je règle ma sortie sur 24hz. Bingo : plus de déchirement, pas de saccade, pas de décalage son. Ça fait une heure que je regarde avec mes enfants qui sont à l'affût de la moindre saccade ou d'effet de déchirement... mais rien !!!

Je ne comprends pas... Mais cette fois, ça a l'air de marcher. Comment ? Pourquoi ? Aucune idée. La seule question maintenant : pour combien de temps ? ;-)
jacquob7
 
Messages: 967
Inscription: 11 Jan 2006 22:39
  • offline


Retourner vers Logiciel PC Home-cinéma