Modérateurs: Staff Installations, Staff DIY, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités

Enceintes en kit, tweaks : modification dans le but d'améliorer une enceinte existante Ex: modif du filtrage... WIY Wire It Yourself - cable le toi-même - est le petit frère de DIY en version plus accessible au débutant.

raspberry = source DIY ?

Message » 04 Oct 2012 18:11

Shinuza a écrit:Si t'as des questions MPD tu peux les poser ici je pense, je connais assez bien la bête et surement que d'autres pourront t'aider. Sinon en parlant de MPD, j'ai un collègue qui à codé ça:


Je voudrais savoir combien de services il est possible de lancer sur le RPi avec des sorties bien précise? J'avait comme idée d'y installer aussi shairport pour que je puisse écouter la musique de mon gsm/tablette (android) dans la salle à manger et cuisine. Pour les salles de bain sa sera pas utilisé, uniquement musique sur NAS et web radio.

C'était pour cette raison que j'avais pensé à 4 RPi, chaqu'un était indépendant des autres et chaqu'un pouvais joué ce qu'il voulais: cuisine shairport, SDB1 web radio, SDB2 musique sur NAS.
TheD6Bel
 
Messages: 81
Inscription Forum: 29 Juin 2012 9:50
Localisation: Bruxelles
  • offline

Annonce

Message par Google » 04 Oct 2012 18:11

 
 
Publicite

 
Encart supprimé pour les membres HCFR

Message » 04 Oct 2012 20:59

Sur ma machine, je peux lancer deux daemons mpd sans swapper. Faut voir si les performances se dégradent avec le swap et le nombre de client (i.e saturation de l'interface réseau).
Shinuza
 
Messages: 93
Inscription Forum: 08 Aoû 2006 13:25
  • offline

Message » 09 Oct 2012 0:34

j'ai mis en route mon raspberry et les résultat est vraiment pas terrible (je pense déjà le revendre) :
-installation de raspbian dernière version + config clé wifi
-compilation de dpflib cf ce topic (HFR), la compilation est longue (25 min) mais tous fonctionne
-installation de mpd +config
-test de la carte son intégré = en effet y a des petit grésillement, pas très agréable
-test avec ma carte te7022+wm8761 = totalement inexploitable, j'ai tenté :

-éditer le fichier /etc/modprobe.d/alsa-base.conf et ajouter à la fin:
Code: Tout sélectionner
options snd-usb-audio nrpacks=1
= plus de message d'erreur dans les log, aucun évolution au niveau de la sortie audio

-éditer le fichier /etc/mpd.conf et modifier les lignes:
Code: Tout sélectionner
audio_buffer_size               "4096"
buffer_before_play              "10%"
= aucun évolution au niveau de la sortie audio

-éditer le fichier /etc/mpd.conf et dé-commenter la ligne:
Code: Tout sélectionner
audio_output_format               "44100:16:2"
= plus de grésillement l'écoute ce fait correctement par contre on supprime tous intérêt pour les cartes son 24/96 ou 24/192

-éditer le fichier /boot/cmdline.txt et ajouter ceci : dwc_otg.speed=1 (force les port usb en mode usb 1.0) source
= la carte son (te7022) ne fonctionne plus, par contre le wifi fonctionne

-éditer le fichier /etc/apt/sources.list et ajouter :
Code: Tout sélectionner
deb http://archive.raspberrypi.org/debian/ wheezy main untested
faire les maj + reboot
= aucune amélioration


à cela s'ajoute :
-3 kernel panic en 1 journée d'utilisation normal :-?
-quand il y accès sur la carte mémoire avec l’ampli à fond on entend des parasites :-?
-à priori rien ne sert de tester les autre distribution vu que d'autre personne rencontre les même problèmes (source)

du coup sauf si quelqu'un a une solution miracle, je peut conclure sans trop me tromper que le raspberry en tant que source audio de bonne qualité n'est pas du tout envisageable (je ne parle pas d'une écoute audiophile)
le coupable est la puce qui gère l'usb, je n'est pas de mot pour décrire cette **********

avec mon dockstar je n'avais aucun de ces problème sauf que lui il n'a pas les pin GPIO

à part la beaglebone, y a t'il d'autre carte pouvant être utiliser pour créer une source DIY?
coOlibry
 
Messages: 216
Inscription Forum: 06 Mar 2011 23:17
Localisation: 85
  • offline

Message » 09 Oct 2012 1:11

C'est une carte avec une alimentation séparée? J'ai zéro soucis avec la mienne (PCM1796). La carte son intégrée est inutilisable pour un usage audiophile.
Shinuza
 
Messages: 93
Inscription Forum: 08 Aoû 2006 13:25
  • offline

Message » 09 Oct 2012 9:32

Humm, le RPI n'est pas en cause. Plusieurs choses :
- Le soft est pas sec, mais ça s'améliore de jours en jours. Quelle version de kernel sur ton RPI ?
- En l'état actuel des choses, soit on s’intéresse à l'embarqué, on s'y met a fond et c'est du lourd pour quelqu'un qui part de rien, soit on attends que le boulot soit fait et stabilisé. Le plus gros du taf a faire est dans un premier temps sur le kernel ...
- le bruit ampli a fond sur la sortie son intégré est normal. Le contraire aurait été étonnant. C'est by design ....
- RPI, Beaglebone etc ... même combat. Tout hardware récent va nécessiter un certain temps pour que le soft se stabilise surtout que le kernel Linux est en pleine réorganisation (pour le meilleur) de toute la partie ARM en ce moment. Tout devrai être plus simple ensuite.
Tazz28
 
Messages: 2802
Inscription Forum: 03 Nov 2008 23:47
Localisation: Dreux
  • offline

Message » 09 Oct 2012 12:38

@Shinuza :
j'utilise l'alimentation du raspberry, l'alimentation utilisé pour celui ci est un chargeur HP touchpad 5V 2A officiel,
maintenant je peut utiliser un alim séparé pour ma carte te7022, mais je n'est pas encore testé,
ton dac utilise une puce pcm1796 mais elle ne gère pas l'usb, c'est quel puce qui gère le usb ?

@Tazz28:
j’espère me tromper pour ma conclusion,
-j'utilise le kernel version 3.2.27+ #244
-pour les kernel panic, j'ai pas l'impression que ce soit ça, j'ai branché un clavier pour pouvoir faire des vérifications
-pour le moment d'un point de vue usage je fait la même chose avec le dockstar, sauf que avec celui ci je n'est aucun problème
ce qui pose le plus problème sur le raspberry c'est le pilote pour l'usb (la puce SMSC LAN9512), je ne sait pas si une solution sera possible
coOlibry
 
Messages: 216
Inscription Forum: 06 Mar 2011 23:17
Localisation: 85
  • offline

Message » 09 Oct 2012 13:56

Étrange ce problème de parasites. Je teste en ce moment moi aussi un Raspberry Pi avec la carte son interne actuellement et pour l'instant aucun pb de parasite.

Par contre pas de Wifi pour moi , j'utilise la sortie filaire éthernet. Ma bibliothèque est sur un NAS. Je fais un montage SAMBA depuis le RPI. J'ai fait une carte SD avec la dernière version Raspian et installer mpc/mpd (sudo apt-get install mpc mpd). Je regarderai mon mpd.conf ce soir. Le Raspberry est alimenté par mon hub USB (alimenté).

La qualité n'est pas tip/top sur la sortie jack stéréo mais pas de problème de parasites. Je n'ai lu que des fichiers FLAC 16/44.1, je testerai des fichiers 24/96 pour m'assurer que ça passe.

Je pense passer à une carte son USB avec un bon DAC pour monter en qualité. De ce que j'ai compris la connexion ethernet est gérée par le contrôleur USB et je me demande si l'accès concurrent du réseau et du flux audio USB ne va pas poser problème ?

A priori chez vous sur la sortie analogique il y a aussi des grésillements ? Le fait de "baisser" la sortie en 16/44.1 ayant amélioré les choses cela semble plutôt indiquer qu'en baissant le débit on supprime ou atténue le problème. Vos fichiers musicaux se trouvent sur quel support ?

Il faut arriver à déterminer si ces parasites sont dus à un pb de goulet d'étranglement au niveau du contrôleur USB auquel cas une mise à jour des drivers ou l'optimisation de buffers peut améliorer les choses sans trop de garantie ou bien s'il s'agit de parasites véhiculés lorsque le processeur est chargé (sollicitation + importante de l'alimentation) auquel cas il faudrait isoler l'alim carte son de celle du RPI. J'ai déjà eu ce cas sur un autre équipement.
eaugier
 
Messages: 66
Inscription Forum: 22 Fév 2005 19:06
Localisation: Alpes de Haute Provence
  • offline

Message » 09 Oct 2012 14:57

Ce qu'il décrit ressemble plutôt à des bruits numériques normaux vu la configuration de la sortie son de la RPI (en amplifiant très très fort derrière).
L'Ethernet sur USB est le - de la RPI., mais le problème est ailleurs : Le core USB du chip broadcom est méchamment buggué et le driver est dans un état lamentable (Synopsys usb driver dwc_otg)
Pour pas arranger les choses, Synopsys ne publie pas les docs et leur driver est pourri.
Enfin, le transcodage fait par le hub USB du chip Ethernet (LAN9512) est bugué et perturbe le core de synopsys. C'est pas étonnant qu'en USB1 forcé plus rien ne marche.

Le support Linux n'est pas encore "mainstream" sur la RPI et tant que ce ne sera pas le cas, toute utilisation "sérieuse" de la RPI risque de poser problème.
Le support commence juste a être mergé et le kernel "spécifique" n'évolue pas beaucoup.

Pour citer Greg K-H pour ceux qui connaissent, à propos de la RPI et de l'USB:
Heck, it's amazing that USB works at all on this hardware in the first
place, Just be happy you are getting _any_ data from it :)

> Is this a known bug? Has anyone seen using vanilla kernel?

You can't use a "vanilla" kernel on the rpi right now, especially for
USB.

> Are there any ideas for what might be going on?

Yes, the hardware is broken, the drivers are broken, and I would not
recommend anyone wanting to do any real USB data transfers to use this
platform at all. Seriously. Go complain to Broadcom if you want to see
this fixed, they are the ones with the specs that we can not get access
to.

Good luck,

greg k-h

ou encore

> "drivers are broken"?

The USB driver code is horrible, really really horrible. Seriously,
it's so bad that no one will touch it, myself included.

> But ... is it related to the fact eth and usb goes through same bus?

Possibly, it's just a really bad USB controller chip, combined with a
sad way to hook it up to the processor, combined with with a truly
horrible driver make for the fact that USB works at all on this board a
total miracle.

And you can quote me on that.

greg k-h


Bref c'est pas gagné, mais faut pas désespérer. Par contre pour l'instant pas étonnant que l'USB soit à la rue .....
Dans quelques itérations du kernel officiel, il sera utilisable sur une RPI et d'ici là le problème de l'USB aura peut être gagné en visibilité.
En tant qu'acheteur de la RPI, tu peux également adresser tes doléances à la fondation pour qu'elle fasse pression sur Broadcom pour que Synopsys release les docs. Ils ont biens trouvé des deals pour les codecs video...

Également, si tu a une version a polyfuse, vire le si tu suspecte un problème d'alim USB.
Tazz28
 
Messages: 2802
Inscription Forum: 03 Nov 2008 23:47
Localisation: Dreux
  • offline

Message » 09 Oct 2012 15:32

coOlibry a écrit:@Shinuza :
j'utilise l'alimentation du raspberry, l'alimentation utilisé pour celui ci est un chargeur HP touchpad 5V 2A officiel,
maintenant je peut utiliser un alim séparé pour ma carte te7022, mais je n'est pas encore testé,
ton dac utilise une puce pcm1796 mais elle ne gère pas l'usb, c'est quel puce qui gère le usb ?
La puce USB c'est une Tenor te7022l. Ça ne m'étonne pas que ta carte pète les plombs, il me semble que les ports USB sont limités à 100mA.
Shinuza
 
Messages: 93
Inscription Forum: 08 Aoû 2006 13:25
  • offline

Message » 09 Oct 2012 17:48

@Tazz28 : le commentaire Greg K-H n'est pas rassurant mais tous à fait réaliste,
surtout à la fin ou il dit que c'est un miracle si l'usb fonctionne

@Shinuza : je sais pas si ma carte consomme plus de 100ma ce que je sais c'est que le raspberry ce plante de manière aléatoire

par contre vu que la puce SMSC LAN9512 est connecté en usb au cpu, j'ai bien envie d'essayé d'utiliser cette sortie usb pour la brancher directement sur un hub usb
les pistes sont toute petite mais ça me semble réalisable
coOlibry
 
Messages: 216
Inscription Forum: 06 Mar 2011 23:17
Localisation: 85
  • offline

Message » 09 Oct 2012 19:22

J'ai fais un petit mail à raspberrypi.org, vu le buzz et la couverture médiatique dont ils profitent, je n’imaginais pas que l'usb de cette plateforme était un tel désastre.
Vérifie si tu as un polyfuse ou pas sur ta version et vire le si c'est le cas.
Si ce n'est un problème de coût, la beaglebone reste une bien meilleure plateforme tant qu'on a pas utilité de l'HDMI.
Tazz28
 
Messages: 2802
Inscription Forum: 03 Nov 2008 23:47
Localisation: Dreux
  • offline

Message » 09 Oct 2012 19:42

la sortie hdmi je n'en est pas besoin,
tous pendant que j'ai un accès ssh et que ça fonctionne en fonction de ce que je souhaite faire, ça me va,
je vais quand même tenté mon bricolage

edit pour les polyfuse:
j'ai ca : Image et a priori les polyfuse c'est ca? : Image
coOlibry
 
Messages: 216
Inscription Forum: 06 Mar 2011 23:17
Localisation: 85
  • offline

Message » 09 Oct 2012 20:04

coOlibry a écrit:la sortie hdmi je n'en est pas besoin,
tous pendant que j'ai un accès ssh et que ça fonctionne en fonction de ce que je souhaite faire, ça me va,
je vais quand même tenté mon bricolage

edit pour les polyfuse:
j'ai ca : Image et a priori les polyfuse c'est ca? : Image



Sur ta photo tu as la version 2 du RPi et sur ce modèle (SI je ne me trompe pas) pas de polyfuse. Il n'y a que sur les première versions des RPi que tu trouvais sa, il y a un autre modèle sans les polyfuse qui corrige les problème d'USB.
TheD6Bel
 
Messages: 81
Inscription Forum: 29 Juin 2012 9:50
Localisation: Bruxelles
  • offline

Message » 09 Oct 2012 20:14

ce n'est pas la photo de la version 2, on peut la voir sur cette page
http://www.pobot.org/-La-carte-Raspberry-PI-.html
et donc oui la version 2 n'a pas de polyfuse

édit:
j'ai tenté de souder les 2 câbles pour l'usb sur la puce smsc (l'endroit le plus accessible),
mais je n'est pas réussi, c'est trop petit par rapport à ce que j'ai, pour les fils j'ai utilisé du câble ide (mono brin)
heureusement j'ai rien cassé, le raspberry fonctionne
coOlibry
 
Messages: 216
Inscription Forum: 06 Mar 2011 23:17
Localisation: 85
  • offline

Message » 10 Oct 2012 21:39

Sorry,

c'est une erreur de ma part, j'ai cru que le trou en haut à droite était le trou de fixation (uniquement sur les rev2) :oops:
TheD6Bel
 
Messages: 81
Inscription Forum: 29 Juin 2012 9:50
Localisation: Bruxelles
  • offline


Retourner vers Kits & Tweaks et WIY

 
  • Articles en relation
    Dernier message