Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 3 invités

A propos de jitter

Message » 27 Jan 2019 15:41

JIM a écrit:Je vais essayer sur ma carte son bouclée mais je pense qu'il n'y aura pas grand chose à voir.
Il y a une sortie firewire via une carte pci propriétaire dans le PC et le rack en lui même.

Le rebouclage, c'est pas du jeu. L'ADC et le DAC utilisent la même horloge, si les deux ont la même latence, ca compte pas.
Le pb du jitter c'est quand tu présentes le bon échantillon , pas au bon moment.
On peut très bien faire du non uniforme sampling (intervalle entre échantillon variable) et avoir un bon résultat si la source (ADC) et la destination (DAC) sont d'accord sur le timing.
Bon, je suis pas clair, mais c'est un concept un peu inhabituel en audio.
https://en.wikipedia.org/wiki/Nonuniform_sampling (bon courage les gars )

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3474
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Annonce

Message par Google » 27 Jan 2019 15:41

 
 
Publicite

 
Encart supprimé pour les membres HCFR

Message » 27 Jan 2019 15:56

Ca fait plaisir de lire ton dernier post, ça me rappelle un échange sur ce forum il y a quelques années lors duquel je tentais d''expliquer pourquoi ce test n'aurait aucun sens. Je me suis fait tacler d'une telle manière désagréable que ça été une des raisons de m'éloigner de ce site :siffle:
Peut-être que le lien fourni convaincra les incrédules :roll:

Pour ton commentaire sur ma vue sur le possible dysfonctionnement dû à la structure même de la couche USB, difficile pour moi de fournir quelques logs que ce soit qui pourraient prouver ce que je dis en créant les conditions pour ce plantage (opérations d'I/O intensives à fort niveau de priorité), je n'ai plus aucune interface audio USB :D
gerardfma
 
Messages: 290
Inscription: 23 Nov 2006 14:46
Localisation: Isere
  • offline

Message » 27 Jan 2019 17:22

gerardfma a écrit:Pour ton commentaire sur ma vue sur le possible dysfonctionnement dû à la structure même de la couche USB, difficile pour moi de fournir quelques logs que ce soit qui pourraient prouver ce que je dis en créant les conditions pour ce plantage (opérations d'I/O intensives à fort niveau de priorité), je n'ai plus aucune interface audio USB

Si j'ai vraiment le temps, j'irais voir les sources des drivers Usb asynchrone Linux, peut être ya-t-il déjà les points de trace nécessaires, sinon il faudra en rajouter.

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3474
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 27 Jan 2019 21:27

Ok mais comment faire alors pour constater quelque chose lié au jitter sur une carte son externe ?

Dans mon cas, il y a quand même 2 sources potentielles de clock (voir plus), ce qui n'est pas forcément le cas de toutes les cartes son.
JIM
Membre HCFR
Membre HCFR
 
Messages: 5588
Inscription: 19 Nov 2001 2:00
Localisation: Toulouse
  • offline

Message » 28 Jan 2019 20:32

Va y essaye , ca coute rien et c'est vite fait.
Ma réponse ci-dessus était un peu rapide, en fait, ça dépend :ane:

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3474
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 29 Jan 2019 20:55

Salut Salut
bien sur j'ai joué avec tes 2 fichiers :)

je confirme ton point, en fait quand on mesure une carte I/O en rebouchant Entrée et sortie, on a une vue très réduite du vrai jitter puisque (normalement) le sampling de l'adc est synchrone avec celui du dac.

alors en rebouclant l'appareil de mesure RTX6001 et en jouant le fichier jtest par audacity en 48khz et en affichant la fft REW ca donne cà avec un zoom entre 10 et 14k. léger phase noise et d'ailleurs j'aimerais bien comprendre d'ou il vient...
RTX JTEST.png


après j'ai essayé de faire la même manip avec la carte motu 8A mais ca mer douille complètement au niveau des drivers : impossible d'envoyer un flux depuis audacity et de le récupérer dans REW. je me démonte pas, comme ca marche avec le RTX j'ai relié la sortie analogique du RTX en mode 10Vrms vers l'entrée analog de la motu 8A et inversement la sortie 1 de la motu va vers l'entrée du RTX. et au niveau du logiciel de matriçage, je demande que analogin1 aille vers analogout1: résultat:
MOTU8A JTEST AnalogLoopRTX (10V).png


le jitter apparait avec les 2 petites bosses autour de la raie 12k et le phase noise est plus grand. Aussi il contient le jitter du RTX qui doit s'ajouter...
globalement ca reste extrêmement performant, cette motu, son horloge et son dsp ne fichent pas beaucoup le binz en rebouclage en tout cas

ensuite j'ai refait ce même test, mais en changeant le matriçage interne de la motu pour que l'entrée analogique aille vers la sortie toslink et inversement. en mettant un cable optique à 2 balles j'obtiens exactement la même courbe. ce qui tend à démontrer que les transmetteurs récepteurs optique ne change pas grand chose au jitter mais ce qui compte c'est la PLL de réception.
Avatar de l’utilisateur
maxidcx
Membre HCFR Contributeur
Membre HCFR Contributeur
 
Messages: 2978
Inscription: 25 Avr 2007 10:50
  • offline

Message » 29 Jan 2019 22:31

maxidcx a écrit:alors en rebouclant l'appareil de mesure RTX6001 et en jouant le fichier jtest par audacity en 48khz et en affichant la fft REW ca donne cà

:o Tu en as des beaux appareils

maxidcx a écrit:avec un zoom entre 10 et 14k. léger phase noise et d'ailleurs j'aimerais bien comprendre d'ou il vient...

Fait attention dans le RTA du windows que tu utilises. Aucun n'est parfait. Il y un compromis , précision en fréquence , précision en amplitude.

maxidcx a écrit:après j'ai essayé de faire la même manip avec la carte motu 8A mais ca mer douille complètement au niveau des drivers : impossible d'envoyer un flux depuis audacity et de le récupérer dans REW.

oui moi aussi. Il semble que REW prenne le contrôle de toute la carte. (quelle idée aussi d'écrire un truc en java :roll: )

maxidcx a écrit:le jitter apparait avec les 2 petites bosses autour de la raie 12k et le phase noise est plus grand. Aussi il contient le jitter du RTX qui doit s'ajouter...

marche pas mal ce test de jitter

maxidcx a écrit:ensuite j'ai refait ce même test, mais en changeant le matriçage interne de la motu pour que l'entrée analogique aille vers la sortie toslink et inversement. en mettant un cable optique à 2 balles j'obtiens exactement la même courbe. ce qui tend à démontrer que les transmetteurs récepteurs optique ne change pas grand chose au jitter mais ce qui compte c'est la PLL de réception.

Oui, mais des récepteurd/transmetteurs toslink de basse qualité avec une bande passante réduite, n'aident pas non plus.
Dans mon (mini PC), je pense que la sortie optique est juste nulle.

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3474
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 25 Mai 2019 17:19

2 round

PC -> USB -> Matrix -> analogique -> FocusRite Solo ADC :
PCUSB.png
PCUSB.png (19.25 Kio) Vu 123 fois

Non mais sérieusement ....
Magnifique bruit de phase

PC -> TosLink S/PDIF -> Matrix -> analogique -> FocusRite Solo ADC :
PCoptic.png
PCoptic.png (18.6 Kio) Vu 123 fois

C'est beaucoup, mieux pour le bruit de phase
Il y a quand même quelques problèmes :
- dégradé harmoniques du signal à Fs/192 non régulie
- autour du Fs/4 c'est pas très propre avec plusieurs pics symétriques.

PC -> USB -> Gustard U12 -> coax S/PDIF -> Matrix -> analogique -> FocusRite Solo ADC : (La Gustard U12 est une interface USB xmos )
gustardcoax.png
gustardcoax.png (18.69 Kio) Vu 123 fois

Une nette amélioration :
- harmoniques du Fs/192 correctes
- plus de pics autour du Fs/4 (par contre peut être un peu plus de bruit)

A noter que je ne m'explique pas le bruit de 11 à 15k présent dans tous les cas. Il ne provient pas de la FocusRite qui a un seuil de bruit parfaitement plat.

Bref, L'USB asynchrone ca marche et en plus c'est mesurable avec des petits moyens.

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3474
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline


Retourner vers Sources et DAC

 
  • Articles en relation
    Dernier message