Modérateurs: Staff Multimédia, Staff Juridique • Utilisateurs parcourant ce forum: kasuki, peperounet et 21 invités

Emissions, programmes, chaînes TV & Radio, mais aussi podcasts, webcasts...

Youtube son 5.1 ?

Message » 22 Juil 2021 8:04

SuperLumberjack a écrit:J'ai créé une petite vidéo avec son 5.1 pour YouTube :)



Donc le jour où l'on pourra réellement sortir du son 5.1 à partir de YouTube, on le saura très vite avec cette vidéo...
Merci
Reste à Google de faire le boulot....ça me paraît incroyable que ce ne soit pas proposé

Envoyé de mon Pixel 5 en utilisant Tapatalk
Fabrice33
 
Messages: 35
Inscription Forum: 10 Jan 2006 22:54
  • offline

Annonce

Message par Google » 22 Juil 2021 8:04

 
 
Publicite

 
Encart supprimé pour les membres HCFR

Message » 22 Juil 2021 9:08

Il faudrait aussi (a minima) qu'ils assurent une compatibilité AC3 (Dolby Digital) : c'est dans le domaine public depuis un bout de temps déjà

La configuration dans mon profil


Membre de l'association pour l'hégémonie du Sacd multicanal
Et sinon, (re)venez visiter le site passionnant des passionnés de la marque d'enceintes Cabasse :
Le forum Cabasse : https://www.forumcabasse.net
Avatar de l’utilisateur
domin
Administrateur Forum Home-Cinema
Administrateur Forum Home-Cinema
 
Messages: 8434
Inscription Forum: 11 Oct 2002 10:20
Localisation: Alsace
  • online

Message » 22 Juil 2021 11:16

Le son est en réalité converti en AAC 5.1 sur YouTube. Je ne sais pas en fait si YouTube reconnait de l'AC3 5.1 à la source, effectivement. Mais sachant qu'il m'a reconnu mon son en FLAC 5.1, il y a peut-être des chances que ça l'AC3 fonctionne :)

Mais comme dit, au final ce sera de toute façon converti en AAC 5.1. Donc à part sortir ensuite en PCM 5.1 vers l'ampli, je ne vois pas... :-?
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 22 Juil 2021 11:48

Ben quand je vois tous les tests Dolby qui trainent qui sont a priori en 2.0, je me dis que le Dolby Digital 5.1 envoyé doit être réencodé en 2.0.

Mais je peux me tromper.

La configuration dans mon profil


Membre de l'association pour l'hégémonie du Sacd multicanal
Et sinon, (re)venez visiter le site passionnant des passionnés de la marque d'enceintes Cabasse :
Le forum Cabasse : https://www.forumcabasse.net
Avatar de l’utilisateur
domin
Administrateur Forum Home-Cinema
Administrateur Forum Home-Cinema
 
Messages: 8434
Inscription Forum: 11 Oct 2002 10:20
Localisation: Alsace
  • online

Message » 22 Juil 2021 11:54

Je testerai plus tard pour voir quand j'aurai plus de temps :wink:
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 22 Juil 2021 13:11

J'ai rapidement testé en envoyant une vidéo avec du son en AC3 5.1 dont voici le MediaInfo :

General
Unique ID : 105044290642856779626472289179068406040 (0x4F06CB6346F48B5182D4AEE1F90A1918)
Complete name : K:\Test 5.1 AC3.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 1.53 MiB
Duration : 14 s 522 ms
Overall bit rate : 881 kb/s
Encoded date : UTC 2021-07-22 10:27:01
Writing application : HandBrake 1.2.2 2019022300
Writing library : Lavf58.20.100 / Lavf58.20.100
ErrorDetectionType : Per level 1

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.2
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 14 s 517 ms
Bit rate : 224 kb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 60.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.000
Stream size : 396 KiB (25%)
Writing library : x264 core 157 r2935 545de2f
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=600 / keyint_min=60 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=6.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=300000 / vbv_bufsize=300000 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00
Default : Yes
Forced : No
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709
DURATION : 00:00:14.522000000

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : A_AC3
Duration : 14 s 522 ms
Bit rate mode : Constant
Bit rate : 640 kb/s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE

Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 spf)
Compression mode : Lossy
Delay relative to video : -5 ms
Stream size : 1.11 MiB (73%)
Title : Surround
Default : Yes
Forced : No
DURATION : 00:00:14.304000000


Et voici le MediaInfo de la vidéo ensuite téléchargée de YouTube :

General
Unique ID : 265240988158325101562485506701919601754 (0xC78B8E60531DB7A560AC077FCBA5445A)
Complete name : K:\Test 5.1 AC3 - résultat YouTube.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 1.32 MiB
Duration : 14 s 592 ms
Overall bit rate : 757 kb/s
Writing application : Lavf58.29.100
Writing library : Lavf58.29.100 / Lavf58.29.100
ErrorDetectionType : Per level 1

Video
ID : 1
Format : VP9
Codec ID : V_VP9
Duration : 14 s 600 ms
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 60.000 FPS
Default : Yes
Forced : No
DURATION : 00:00:14,516000000

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : A_AAC
Duration : 14 s 592 ms
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE

Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 spf)
Compression mode : Lossy
Default : Yes
Forced : No
DURATION : 00:00:14,592000000


Le format 5.1 est donc bien préservé :wink: Mais comme dit, ce sera à chaque fois converti en AAC 5.1.
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 22 Juil 2021 15:50

Donc en théorie il y a des vidéos 5.1 sur Youtube, le souci c'est de définir la méthode pour les lire en 5.1

La configuration dans mon profil


Membre de l'association pour l'hégémonie du Sacd multicanal
Et sinon, (re)venez visiter le site passionnant des passionnés de la marque d'enceintes Cabasse :
Le forum Cabasse : https://www.forumcabasse.net
Avatar de l’utilisateur
domin
Administrateur Forum Home-Cinema
Administrateur Forum Home-Cinema
 
Messages: 8434
Inscription Forum: 11 Oct 2002 10:20
Localisation: Alsace
  • online

Message » 22 Juil 2021 17:37

Oui, il y a bien des vidéos en 5.1 sur YouTube, et même des vidéos en HDR :D
Mais certaines ne le sont pas réellement.

Le meilleur moyen de vérifier c'est avec 4k Video Downloader.

En fait, je crois qu'à une époque c'était possible de sortir du 5.1 de YouTube avec le HTML5 à partir d'un navigateur internet. Puis apparemment ça a de nouveau été limité en stéréo par la suite. En tout cas c'est ce que j'avais lu une fois.

Je crois que la seule chose à faire est d'attendre que YouTube le propose en fait :-?

Faut avouer que c'est quand même assez dingue en 2021 de ne pas pouvoir sortir de 5.1 d'un navigateur internet. Avec Amazon Prime Video par exemple, pas possible non plus.

Faut passer par des boxs et des apps apparemment.
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 25 Juil 2021 17:59

Désolé, j'ai juste refait la vidéo ci-dessus, car en fait je me suis rendu compte qu'il y avait une grosse perte de qualité au moment de convertir la matrice de couleurs du Rec.601 vers du Rec.709 :-? Et perso j'essaye toujours de maintenir le maximum de qualité jusqu'au bout, même si YouTube recompresse tout ensuite à la truelle...



En fait, je m'explique. C'est l'une des premières fois que j'ai utilisé la fonction ShadowPlay de ma carte graphique Nvidia. Sauf que les vidéos capturées utilisent une matrice de couleurs Rec.601 au lieu de Rec.709 (en plus d'un framerate variable), et donc je dois convertir l'espace de couleurs pour avoir les couleurs correctes sur YouTube.

Or ce que je n'avais pas remarqué, c'est que VirtualDub m'a pas mal dégradé les couleurs après cette conversion (ça se remarque notamment dans les rouges). Et pourtant j'utilise un codec sans perte !

Voici une image 1080p zoomée 8X de l'original en YUV 4:2:0 Rec.601 :

Image

Puis le résultat de la conversion en Rec.709 avec VirtualDub :

Image

Comme on peut le voir, ça bave dans les rouges :ko:
En fait, c'est sûrement la conversion YUV 4:2:0 Rec.601 vers YUV 4:2:0 Rec.709 qui est très destructrice.

En revanche,j'ai pu constater qu'avec Sony Vegas c'est beaucoup mieux ! :D

Image

Bref, donc j'ai refait ! :siffle:


A part ça, la compression sur YouTube est quand même assez crade par moment, notamment en 1080p... :grr:
Suffit de comparer ! :P

YouTube 1080p codec AVC :

Image

YouTube 1080p codec VP9 :

Image

En revanche en 4k c'est déjà beaucoup mieux ! :ohmg:

YouTube 4k codec VP9 :

Image

Le fichier original en 4k :

Image

Bon, c'est clair que c'est une scène compliquée, car même sur l'original c'est un peu brouillon par endroit. Le 4k de YouTube s'en sort pas trop mal, même si l'image est plus floue et que l'on perd des détails par endroits.


A part ça, je viens de penser à un truc concernant l'app YouTube sur les TV Android.

J'avais testé sur la TV de mes parents lorsque je suis passé chez eux pour leur paramétrer l'application Amazon Prime Video. Or ils ont un vieux kit Logitech Z-5400 qui est 5.1... et celui-ci ne décode pas le PCM 5.1 ! :)

Je rappelle que le son 5.1 sur YouTube est en AAC, pas en AC3. Donc logiquement il faut forcément pouvoir décoder du PCM 5.1, vu que la seule possibilité à mon avis est que ce soit converti en PCM 5.1 en sortie.

Donc je ne peux pas affirmer pour le moment que l'application YouTube ne permette pas de sortir du 5.1.

Moi en revanche, j'ai un ampli Yamaha qui décode parfaitement le PCM 5.1, sauf que je n'ai pas de TV avec Android... :mdr:

Par contre, je viens de commander un Amazon Fire TV Stick 4K (car il n'est pas trop cher) et que je veux absolument pouvoir profiter des programmes d'Amazon Prime Video avec du son 5.1.

Malheureusement l'application Windows 10 ne le permet pas... allez comprendre ! :hein:

Bref, avec ce stick je vais pouvoir tester l'application YouTube et voir si ça me sort du son 5.1 :wink:
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 27 Juil 2021 22:39

Pas de son 5.1 sur l'application YouTube à partir du Amazon Fire TV Stick 4K, que du stéréo ! :roll:

Par contre autrement le son 5.1 fonctionne parfaitement avec ce stick. Pas de souci avec Amazon Prime Video par exemple. Donc c'est bien YouTube qui bride le son en 2.0.
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 28 Juil 2021 8:34

SuperLumberjack a écrit:Pas de son 5.1 sur l'application YouTube à partir du Amazon Fire TV Stick 4K, que du stéréo ! :roll:

Par contre autrement le son 5.1 fonctionne parfaitement avec ce stick. Pas de souci avec Amazon Prime Video par exemple. Donc c'est bien YouTube qui bride le son en 2.0.
Merci pour ce retour .
YouTube bien à la traîne

Envoyé de mon Pixel 5 en utilisant Tapatalk
Fabrice33
 
Messages: 35
Inscription Forum: 10 Jan 2006 22:54
  • offline

Message » 28 Juil 2021 11:55

Yep ! Malheureusement... :-?

Mais Facebook, c'est pire ! Je donne ça comme exemple, même si ce n'est pas à proprement parler une plateforme dédiée exclusivement aux vidéos, mais vraiment c'est une catastrophe ! :ko:

Non je dis ça parce que des fois il m'arrive de poster des vidéos de vieux jeux vidéo dessus (nostalgie, quand tu nous tiens) et là, en plus de n'avoir que du stéréo, tout ce que j'uploade à partir de la résolution 1080p finit par être downscalé en 720p, il n'y a que du 30 fps (et la conversion de 60 fps à du 30 fps est mal faite si jamais on a la mauvaise idée d'envoyer un fichier en 60 fps) et la qualité vidéo et audio sont médiocres.

Mais le pire que j'ai pu constater, c'est que souvent après quelques temps, je perds les résolutions HD de certaines de mes anciennes vidéos ! Je me retrouve donc avec des vidéos en 240p :o

Désolé, je sais que ça n'a un peu rien à voir, mais ça me fait du bien d'en parler :mdr: Ce réseau social est archaïque, en plus d'être une usine à bugs !

En revanche, je serais curieux de voir ce que donne Vimeo avec du son 5.1 :) Malheureusement, c'est payant.
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 13 Sep 2021 13:34

Pas encore reussi a avoir une bande son coorecte 5.1 sur youtube sur apple tv.
Les canaux semblent mélangés... Arriere droit au lieu de centre...
Sur l'app youtube de ma tv LG c'est le même topo...
Je me delande si ma barre a pas un souci.
Du coup je vais tester avec un mkv.
loic69
 
Messages: 2632
Inscription Forum: 18 Avr 2004 12:33
Localisation: Savoie
  • offline

Message » 13 Sep 2021 20:48

Non mais laisse tomber. Malheureusement pour l'instant on ne peut sortir que du son stéréo sur YouTube :-?

Il faut attendre qu'ils décident enfin de se bouger l'arrière-train chez Google.
SuperLumberjack
 
Messages: 3284
Inscription Forum: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 13 Sep 2021 20:56

Ok tu me rassures
Mais pk certains disent qu'ils dowscale en aac 5.1 ?
Je vais quand même tester avec un mkv par acquis de conscience.
loic69
 
Messages: 2632
Inscription Forum: 18 Avr 2004 12:33
Localisation: Savoie
  • offline


Retourner vers Chaines et Emissions TV, Radio et Internet

 
  • Articles en relation
    Dernier message