Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: vannhoem et 7 invités

Circlotron

Message » 04 Avr 2019 17:36

Pour le générateur de courant je pourrais me baser sur ce qui est fait dans le Aleph P 1.7 au lieu de la Zener ?

http://www.kk-pcb.com/a17serv.pdf
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Annonce

Message par Google » 04 Avr 2019 17:36

 
 
Publicite

 
Encart supprimé pour les membres HCFR

Message » 05 Avr 2019 16:40

bon après quelques simules, je sèche un peu sur ce schéma. il y a quelque chose d'intéressant avec ce montage des mosfet, mais je trouve que ca emmena trop loin sur les contraintes d'alimentations. Par exemple ton montage avec 2 aop, ok, mais il faut une alimentation +/-24v secondaire. pff. trop lourd. j'arrive pas à comprendre l'avantage technologique par rapport à un simple push-pull de mosfet alimenté symétriquement par rapport au 0volt. A la fin, ce qui compte c'est le temps de monté, l'imd, la thd, la stabilité, le bruit et le cout complet, je reste sur l'ACT1... courage :)
Avatar de l’utilisateur
maxidcx
Membre HCFR Contributeur
Membre HCFR Contributeur
 
Messages: 2991
Inscription: 25 Avr 2007 10:50
  • offline

Message » 09 Avr 2019 13:40



Bonjour,

En simulation j'avais augmenté R5 et R6, (r de drain) parce que ça diminuait la distorsion de l'ensemble, mais ce n'est pas forcement une bonne chose pour l'étage suivant qui a une capacité d'entrée.

Vous auriez un avis sur la question ?

Merci
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 23 Mai 2019 14:12

Bonjour,

Voici une version plus simple, se rapprochant de ce que je voulais à l'origine, mais à Hexfet en sortie, je ne peux plus utiliser de latfet.

Néanmoins le circuit semble stable en température grâce au système que m'a donné Joe Berry https://patents.google.com/?inventor=Jo ... rman+Berry

340ma 20°
300mA 40°
245mA 70°

Plus de double alimentation, l'alim flottante suffis. (Joe Berry)
Plus de CSS sur l'étage d'entrée, retour à la polarisation auto comme le Zenquito, UGS, avec la même polarisation que le F5 et le BA3 à 75% de l'IDSS.
J'ai diminué la tension d'alim des deux premiers étage pour pouvoir utiliser des TO92 même en vas (200mW c'est correct ?)

J'aimerais commencer les tests en RÉEL mais avant ça il faut que je sache si je ne suis pas entrain de faire un SUPER OSCILLATEUR , je ne connais pas du tout cette partie.... quelqu'un pourrait m'aider à vérifier sa stabilité en simulation ?

Merci BEAUCOUP

Image

Fichier LTSPICE
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 23 Mai 2019 21:16

La configuration dans mon profil


J'avais la télé, mais ça m'ennuyait, je l'ai r'tournée. D'l'aut' côté c'est passionnant
Avatar de l’utilisateur
tcli
Membre HCFR
Membre HCFR
 
Messages: 3496
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • offline

Message » 23 Mai 2019 21:55

Bonsoir, j'avais déjà trouvé ce site là il y a quelque temps, mais merci

ils on aussi une version à transistor :

http://www.solen-audio.fr/amplificateur ... stor-ct50/
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 23 Mai 2019 22:43

Salut il faut que tu regardes le tutoriel you tube ltspice loop gain. et tu trouveras dans la librairie un example avec les sondes et les formules.
tu RUN la simule et si le déphasage passe en dessous de 45deg à 0db de loop gain alors ca craint :ko:
Avatar de l’utilisateur
maxidcx
Membre HCFR Contributeur
Membre HCFR Contributeur
 
Messages: 2991
Inscription: 25 Avr 2007 10:50
  • offline

Message » 24 Mai 2019 8:52

OK merci, je vais regarder la video, pour le moment j'ai essayé le carré 4V 1khz avec 1uF en sortie.... :ko: :ko: c'est pas beau
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 24 Mai 2019 10:30

re bonjour, le problème avec les tuto ltspice c'est que les amplis ne sont pas symétrique

Si je trouvais un exemple avec un ampli UP ou un aleph X ça changerait tout

J'ai mis 47P entre base de collecteur, le carré semble se stabiliser

Image
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 24 Mai 2019 14:02

Salut Ultimate,
Ce montage fonctionne, il est malin, mais n'est pas inconditionnellement stable.
Vis à vis de ton schéma, sur charge résistive,
Image
Pour juger de la stabilité, il faut tout d'abord supprimer C2 et C3. Puis ensuite veiller à ce que la réserve de phase soit au moins égale à Pi/4 (45°). Pour y parvenir C4=C5=330pF. La bande initiales est écourtée, mais reste supérieure à 400kHz, ce qui est largement suffisant.
les // (R3,R20) et (R16,R21) dont chaque équivalent est= 332,5 Ohms peuvent être remplacées par un équivalent de 420 Ohms pour porter le gain à 26dB, valeur adoptée très fréquemment dans les amplis pro.
C1=1mF =1000µF est sur évalué. Il peut être ramené à 100µF. Il n'y a aucune incidence dans les fréquences basses (< 20Hz).
R14 est inutile. Le dosage de R13 est pointilleux. Je te conseille de la remplacer par une R=180 Ohms fixe // à (3.6k fixe+ 2.2k variable). La valeur totale utile se situe vers 4.78k. La position de la R variable se situera proche de sa mi course.

Le schéma correspondant à ce bavardage. Attention, les repères des résistances diffèrent de ton schéma .
Image
Le diagramme de bode correspondant; Ca est porté à 100 fF (femto Farad) ce qui revient à supprimer l'effet de C2 et C3.
Image
Sur lequel tu peux constater une réserve de phase de l'ordre de 50° (donc > à 45°). Un zoom sur le diagramme de Bode:
Image
Réponse à un signal rectangulaire de 10kHz, sur charge résistive de 8 Ohms; C2,C3 considérés déconnectés( Ca=100 fF)
Image
Réponse à un signal rectangulaire de 10khz, sur une charge capacitive de 10µF; C2,C3 considérés déconnectés( Ca=100 fF)
Image

Le 2SK170BL est obsolète. On en trouve à des prix délirants. A mon gout la recherche d'un remplaçant s'impose.
J-C.B
 
Messages: 6111
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie
  • offline

Message » 25 Mai 2019 12:11

Un grand merci Jean Claude, tu n'imagine pas le plaisir que tu me fais la.

Je ne suis pas la maison ,je suis sur mon téléphone, je répondrais un peu plus tard
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 25 Mai 2019 13:54

tu n'imagine pas le plaisir que tu me fais la.
J'en suis ravi. Mais c'est en fait ta ténacité qui va te permettre d'aboutir.
Je ne vois qu'un léger premier défaut à ce montage. Chacune des deux sorties est pourvue d'un offset non nul.
Dans la pratique ces offsets de sorties étant quasi égaux, le courant qui en découle et circule à travers la charge est négligeable, voir nul. Donc, tout va bien sur ce point.
Le second défaut , à mes yeux, est un courant de repos de 300mA, ce qui me semble excessif, mais la encore, rien de rédhibitoire.
Image

Il me semble qu'il faut voir le circlotron comme un bridge, très astucieux.
J-C.B
 
Messages: 6111
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie
  • offline

Message » 25 Mai 2019 22:46

re bonjour Jean Claude, merci pour tes conseils je les appliquerais dans le prochain schéma.

J'ai plusieurs réponses et plusieurs questions, je vais donc les numéroter.

1) Je vois que tu as augmanté la compensation à 330p que j'avais placé entre la base des bipolaires et la sortie de l'ampli pour éviter de charger trop ce transistor,
il a déjà bien assez à faire avec la capacité de l'étage de sortie,
or après vérification sur carré j'avais vu que l'ampli était plus stable en la plaçant entre la base et le collecteur.

Du coup, quel serrait le meilleur placement ?

2) le 2SK170BL est effectivement obsolète, mais j'en ai quatre à idss 8mA d'où leur présence dans le schema, j'ai aussi des 2SK389BL dans un sachet.

Les LSK170 ou LSK389 aussi sont disponible chez Micross mais je suis ouvert à toutes propositions.
https://shop.micross.com/pdf/LSM_LSK389C_TO-71.pdf

Que pense tu des J113 pas cher et dispo chez mouser ?

3) l'offset en sortie... oui...MAIS... avec cette contre réaction il n'y en a plus, j'avais trouvé cette contre réaction sur un forum Russe il y a 4ans, mais il est n'est pas évident d'obtenir le courant et le gain désiré donc je l'avais mis de coté, les transistors utilisé était en série V donc a haut IDSS

Image

L'utilisation des IRF9620 avec leur capa énorme permet normalement de se passer de compensation, mais leur grand ecart en tension de seuil m'avait amené vers les bipolaires que j'ai déjà aussi en quantité BC560C

4) du coup J113 ou 2SK/LSK ? IRF ou BC560 ? IRFP140n ou 150n ?

Merci, bien à toi, Sébastien
Dernière édition par UltimateX86 le 26 Mai 2019 18:53, édité 1 fois.
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 26 Mai 2019 16:02

Avec des 2sk170 8mA idss on est à 2.7mA avec 10ohm pour R17 et 100ohm pour R3/R16

Concernant le bias des mosfets tu voudrait baisser à combien ?

Juste pour info, je faisais mes simulations sous 40°, je ne sais pas si c'est "la norme"
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline

Message » 26 Mai 2019 19:11

Bonjour, je viens de repérer un souci lors de la simulation PULSE sous ltspice, lorsque je branche le générateur pulse ça me change la polarisation de l'ampli !

il ne faudrait pas revoir les résistances avant les Jfet ?
UltimateX86
 
Messages: 3829
Inscription: 27 Oct 2002 21:13
  • offline


Retourner vers Amplis et Préamplis