Modérateurs: Staff DIY, Staff Installations, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 5 invités

Le "FastTrack 50W" ... LM3886+AOP en config Compound

Message » 18 Avr 2014 15:19

Yuli_35 a écrit:
note: Quand j'écris VPP - je veus dire Peak to Peak. Donc 40VPP veut dire signal +20/-20V. Vpeak = 20V.


Ah ok, je pige mieux. Sorry :oops:
Y a pas un peu trop de fumeurs de moquette par ici ?
androuski
Membre HCFR
Membre HCFR
 
Messages: 14858
Inscription: 14 Mar 2007 14:43
  • online

Annonce

Message par Google » 18 Avr 2014 15:19

Publicite

 
Encart supprimé pour les membres HCFR

Message » 18 Avr 2014 16:18

Ah ok, je pige mieux
Oups, moi aussi. :wink:
Dernière édition par J-C.B le 18 Avr 2014 19:54, édité 1 fois.
J-C.B
 
Messages: 5059
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

Message » 18 Avr 2014 19:13

:D Non,non Gilles tu as raison.

une valeur Eff d'un carré redréssé=valeur crête.
Image

elle passe la simu ?
thierry38efd
 
Messages: 1735
Inscription: 18 Sep 2013 7:36
  • offline

Message » 18 Avr 2014 19:28

thierry38efd a écrit:
le modèle est très complexe,plein de subckt.(crypté!) sans ground.(flottant).

Oui, mais justement , je crois me souvenir qu'il est fantaisiste du point de vu stabilité.

thierry38efd a écrit:Klaus sur diyaudio a créé son modèle pour l'analyse AC (stabilité)

C'est très intéressant, ca permet enfin de faire des simus où l'on peut controler la stabilité.
Sans ça, il est inutile d'essayer de simuler des montages a la Yuli_35 ( ou MyRefC).
J´avais la télé, mais ça m´ennuyait. Je l´ai r´tournée... d´l´aut´ côté c´est passionnant
tcli
Membre HCFR
Membre HCFR
 
Messages: 3027
Inscription: 23 Nov 2009 22:40
Localisation: Complètement à l'ouest
  • online

Message » 18 Avr 2014 20:48

Oups,oups,oups...

je t'ai contacté (avec tous les fichiers) par la boîte mail de hcfr.regardes dans les messages....
Désolé de la confusion,de + ,j'ai ton mail perso... :-?
thierry38efd
 
Messages: 1735
Inscription: 18 Sep 2013 7:36
  • offline

Message » 18 Avr 2014 22:25

Bonsoir a tous,

Alors je vais faire rapide sur les tests que j'ai effectué cet aprs midi.
J'ai changé l'AOP pour un OPA2107. (il a une plus faible bande passante que le LME)
J'ai fait de tests a n'en plus finir, et au final le système devient de plus en plus stable lorsque le gain du LM3886 réduit et celui de l'OPA augmente
Je suis arrivé a une config ou le gain du LM3886 est de 10dB (Gain de x3)
Normalement le LM3886 est instable a ce gain là ! Mais là L'OPA doit avoir une réserve de gain qui fait que ca passe. j'ai du mal a explique le phénomène. la réservede gain de l'AOP compense le LM3886 :o .
J'ai même réduit la compensation de l'OPA a 100pF. J'ai aussi viré la compensation de la Contre réaction globale.

Au final Je n'ai jamais eu une stabilité de ce type. C'est impeccable y compris sur charge complexe.
un 10kHZ
Image

Le problème ... parcequ'il y a toujours un problème ... C'est lorsque le système de protection "spike" s'active .... Ca part en live.
L'AOP essaye de compenser ce comportement et au final on part en oscillations entretenues.
je ne pense pas qu'il soit possible de compenser d'une quelconque façon. il va donc falloir trouver une autre solution.

Je vais réfléchir, mais un limiteur de courant pourrait être une idée.

Si vous avez des idées.

A+ gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 21 Avr 2014 17:51

Hello a tous,

Alors voilà, j’ai passé du temps – beaucoup de temps.
La première étape a été de solidariser le LM3886 au radiateur. Avec un rail en metal. Ainsi le LM3886 est pris en sandwitch entre ce rail et le radiateur.
Resultat : je n’avais plus les perturbations liées à l’activation du mode « Spike » du LM3886.

Par contre le palier supérieur des signaux carrés étaient perturbée par une oscillation a 450Khz (quand le signal en sortie d’ampli dépassait 35-38VPP).
J’ai tenté encore des dizaines de configurations mais ca ne fonctionnait pas , alors j’ai tout foutu en l’air ….

Non je rigole… mais j’ai tout repris de zéro, j’ai donc remis l’ampli en configuration buffer +LM3886 pour voir ce qui se passait (configuration sans compound).
Or sans compound j’avais toujours une perturbation a 450khz sur les paliers des signaux carrés (au dela de 37-38VPP.

J’ai modifié complètement l’alimentation pensant que les perturbations que j’observais étaient liées a cette alim.
Changement des condos, changement de la régulation de l’AOP. Toujours les mêmes problèmes.
Je me suis donc repenché sur la stabilité du LM3886. Et là bingo….

Bon je la fait simple : avec un gain de 7.8 (17.8dB) le LM3886 n’oscille plus . il est à noter que si la compensation était trop importante – ca partait en cacahuète – et pareil si la compensation était trop faible.

DONC : Le LM3886 doit être absolument stable par lui-même avant de le mettre en mode compound.

Mesures effectuées avec un charge de 6.8Ohm.
La charge capacitive est une association de résistance de 0.1 Ohm et 1µF en Série.

Je ne vous fait plus attendre.
note : Le circuit marche tout aussi bien avec l'OpA2107 ou le LME49720
le schéma !!!! c'est ca :
Image



Un signal carré 20khz - 20VPP

Image

Un signal de 20khz – charge capacitive - 20VPP
Image

Signal carré 10k - 40VPP - 50W

Image

Un signal de 10khz – charge capacitive - 35VPP
Image

Un signal de 10khz – 56VPP - 120W !!!!

Image

On l'a traqué ... le démon de la stabilité n'est pas ??? .


Cdlt Gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 25 Avr 2014 22:35

Bonsoir Gilles,

T'es tu intéressé à l’écrêtage de ton montage. Je veut dire par la, à sa symétrie et sa "douceur" lors de l'écrêtage.
Il me semble aussi que la différence de THD entre le LM3886 seul et le montage compound est intéressante. De même la valeur de l'offset de sortie entre les deux peut être significative pour définir l'intérêt du montage.

Cordialement
J-C.B
 
Messages: 5059
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

ECRETAGE

Message » 27 Avr 2014 16:07

Bonjour à tous,

Depuis quelques jours j’ai remis les mains dans mon système de mesures pour la distorsion.
Mon premier souci a été de trouver un driver Windows 7 pour ma carte emu-204.
Ensuite j’ai des plantage intempestifs … le driver est instable – puis il a fallu faire des cables pour tester la carte en rebouclage. Pour info, entre un câble du commerce jack-jack et un câble fait maison je passe de 0.001% de disto a 1khz à 0.0004% de disto (je vous fais grâce des différences suivant les Harmoniques ).
Tout ça pour dire que je ne suis pas prêt de faire des mesure de dito correctes avant a un certain temps.
(ben oui faut s’occuper des chocolats … ça prend du temps de tout manger 8-) )



En attendant et pour répondre à la question de Jean-Claude, voici quelques mesures toutes fraiches concernant la symétrie lors de l’écrêtage.

Bon… Soyons clair, le LM3886 écrête de manière asymétrique – en effet dans le datasheet il est mentionné que le dropout pour le rail positif est d’environ 1.6Volts pour V+=28 et Iout = 100mA.
Pour le rail négatif le Drop out est de 2.5V pour V-=-28V et Iout = -100mA. Cf datasheet page 4
Il n’y a aucune raison pour que l’AOP rattrape ce problème. Je dirais même que lorsque le LM3886 arrive dans ses limites physiques le montage compound AOP + LM3886 a de grosses chances de devenir instable, car l’AOP essayera de compenser ce qui ne peut l’être ! C’est le type de problème auquel j’ai été confronté avec la protection spike.

Les mesures ci-dessous ont été faites avec une alim parfaitement symétrique +36V/-36V (quand on ne lui tire pas dessus et +33/-33V en charge ) et I out 3 Ampères.

Juste Avant écrétage : en rouge la tension du rail négatif.
On voit un petit fourmillement dans la partie négative du sinus ....
Image


Ecrêtage rail négatif ….


Image


Puis écrêtage rail positif et négatif. AIE … c’est pas joli joli !!!! (10khz !!!le signal en entrée).

Image


Bon Il faut savoir que : On a un signal de+31/-31V = 62VPP.
La charge fait 6.8 Ohms …. Puissance dissipée dans la charge = 66W.
Je suis en dehors des specs du LM3886 (enfin il me semble 8-) ).

Maintenant regardons ce qui se passe sur cette alim.
Avant écrêtage (en bleu le signal en sortie d’ampli echelle 10V/unité), en rouge (l’alimentation visualisée en mode AC avec echelle 0.5V/unité.)
En résumé, la tension est passée de -36V a -33V environ, et la tension fluctue de 0.75VPP (ou +/-0.
375V)


Image


Une fois que l’on écrête : en rouge l’alim, en bleu le signal en sortie d’ampli.

Image



Conclusion :
1. On ne peut pas dire que l'écrêtage sest ymétrique et encore moins "doux" - Le Schéma Compound ne peut corriger les défauts a la limites du LM3386 en ce qui concerne l’écrêtage.
2. Il est même fort possible que les oscillation observées – sont a attribuer au montage compound.
3. Je ferai des tests sur le LM3886 seul, mais ce sera pour plus tard.

Note :
1. Il est a noter que j’ai mesuré la tension VPP au sortir d’un autre ampli alimentant des enceintes de 86dB de rendement, et quand j’étais a 35VPP C’était déjà bien fort – j’ai poussé à 50VPP, mais là chez moi je ne tiens pas longtemps.
2. Les mesures effectuées vont au-dela de ce que je peux écouter chez moi 8-)

J’attends vos questions/commentaires.

Cordialement Gilles.
Dernière édition par Yuli_35 le 01 Mai 2014 14:55, édité 1 fois.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 27 Avr 2014 21:02

Hello Gilles,

tu peux insérer un petit montage en entrée avec 2 diodes tête-bêche.
(il y a aussi le schéma NAD soft clipping,mais plus complexe).

faudrait faire le montage avec tina ou ltspice pour fixer des R selon le gain et les rails d'alim.
avec 2x2diodes en série,ça écrêtera à 1.3v crête,0.9v eff.

Image

Image
thierry38efd
 
Messages: 1735
Inscription: 18 Sep 2013 7:36
  • offline

Message » 28 Avr 2014 8:35

Il serait vraiment dommage de faire précéder un montage destiné à la réduction des distorsions, par un réseau qui en génère copieusement.
Il existe une solution simple que l'astucieux Gilles trouvera sans aucun doute. A la seule vue des saturations simultanées de l'AOP et du LM3886 la solution apparait.
J-C.B
 
Messages: 5059
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

Message » 28 Avr 2014 10:28

les diodes en // sont transparentes,c'est un circuit ouvert.(1n4148 par ex)
aucune distorsion supplémentaire.

on peut rajouter 2 ou 3 diodes de puissances rapides sur le rail d'alim positif du lm3886,mais plus cher.
thierry38efd
 
Messages: 1735
Inscription: 18 Sep 2013 7:36
  • offline

Message » 28 Avr 2014 10:39

les diodes en // sont transparentes,c'est un circuit ouvert.(1n4148 par ex)
aucune distorsion supplémentaire.
Non, simule le circuit et tu te rendras compte que la distorsion n'est pas négligeable.
Il suffit de se reporter aux caractéristiques de base d'une diode pour se rendre compte que ce n'est pas un élément linéaire et que de surcroit l'effet d'une variation de température n'est pas anodin.
Ce montage n'est pas à adopter pour des amplis soignés.
J-C.B
 
Messages: 5059
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie

Message » 28 Avr 2014 10:46

Bonjour a tous,

Merci pour vos aides et directions.

Oui Jean claude,

Mes notations :
Vp = Vpeak = 10V
VPP = V peak to peak = 20V
Vrms = Vrms … = 7.07V

Le schéma actuel fait que le LM3886 amplifie le signal de 7.8 fois.
Sachant que le schéma complet amplifie le signal de 34 fois, on en conclue que l’AOp amplifie le signal de 34 / 7.8 = 4.35 fois.

La tension Vpeak en entrée qui fait saturer l’ampli est de 30V/34 = 0.882 Vp
En clair J’ai un signal en entrée qui fait 1.76 VPP ou 0.62VRMS sature l’ampli.

Donc … 0.882* 4.35 = 3.84Vp …. C’est la tension Vp max que l’AOP ne devrait pas dépasser en sortie, si on veut éviter que le LM3886 sature.

Pour limiter la tension en sortie de l’ampli OP on a 2 solutions :
a. Baisser sa tension d’alimentation
La tension d’alimentation de l’AOP est actuellement de +15/-15V. Donc l’outputswing de l’AOP est quasi 4 fois supérieur à celle nécessaire à la saturation de l’ampli. En réduisant l’alimentation de l’AOP a +/-7V, cela devrait arranger les choses (en tout cas La Simulation est correcte) .
b. Baisser son gain.
Si on baisse le gain de l’AOP … L’intérêt du montage compound va se retrouver très limité. En effet il faut que l’AOP puisse corriger les défauts du LM3886.
Fausse bonne idée.
c. Limiter la tension Vp du signal en entrée d’AOP
Solution proposée par Thierry – A étudier coté disto comme indiqué par Jean-Claude.
d. Autre idée ??? baisser le gain du LM3886 (voir ci-dessous)

Suite à la réflexion sur ce point je me suis repenché sur le schéma du Myrefc.
Et je constate que mon schéma a des gains d’aop et de LM3886 très proches du fameux My Refc de Mauro Penasa. De plus …. Je l’avais déjà signalé il alimente l’AOP en +12/-12V, alors que l’aop supporte bien plus. Je pense que justement le concepteur a joué sur ce point pour éviter la saturation pas belle.
Ayant en ma possession un Myrefc, je vais faire des mesures en saturation pour voir ce qui se passe.


Et en cherchant …. (encore Jean- Claude !!!) je viens de tomber là –dessus :
diy-amplification/ampli-4-voies-myrefc-t29965693-165.html

C'est une maladie chronique des montages ayant un aop en entrée. puisque tu disposes d'un montage, soumet l'entrée à une tension qui fasse saturer la sortie et surveille simultanément les tensions de sortie et celle du LM318. Dès l'apparition de la saturation, le LM318 se comporte comme un comparateur, au signal saturé est superposé un signal rectangulaire qui provoque une déformation de la saturation de sortie. L'un des remède possible est d'ajuster le gain de l'étage de sortie à Vsat(de sortie)/Vsat sans dépassement(Aop).


Arrête-moi si j’ai pas bien compris Jean-Claude, mais mon alternative avec la tension d’alim de l’AOP, aura le même effet final que « d'ajuster le gain de l'étage de sortie à Vsat(de sortie)/Vsat sans dépassement(Aop).» tout en garantissant la stabilité du LM3886.

Pour info j’ai testé un gain de x2 (6dB) sur le LM3886, mais je n’avais pas un gain global de x34 mais de 23x. Ce montage était instable dès le démarrage de l’ampli ! sans même un signal en entrée.

il y a peut être un point milieu entre la tension d'alimentation de l'AOP et le gain du LM3886 autre que ce que j'ai trouvé actuellement et qui résout en plus le problème d'écrêtage.

Je sens que de nouveaux tests et mesures sont à faire.

Des indications à me proposer ?

Cordialement Gilles.
Yuli_35
Contributeur HCFR
Contributeur HCFR
 
Messages: 2646
Inscription: 11 Aoû 2006 17:17
Localisation: Rennes

Message » 28 Avr 2014 11:01

Bonjour Gilles,
Tu es sur la bonne voie.
Pour ne rien te cacher, j'ai simulé le LM3886 , dans sa version basique (sans le circuit de muting) et des bipolaires courants.
Image
J'ai pu approcher les problèmes que tu rencontres.
Avec une alim de +/-40v, un gain de 5 du LM et un NE5532 la tension d'alimentation de ce dernier est de +/-9v.
La structure du compound simulé, est celle que j'utilise fréquemment et présente sur l'article que tu rappelles.
Image
Cordialement

PS: C'est la 1° fois que j'utilise Gopix, que faire pour contrôler le format
J-C.B
 
Messages: 5059
Inscription: 19 Juil 2009 12:18
Localisation: Haute Normandie


Retourner vers Amplis et Préamplis