Modérateurs: Staff Home-Cinéma, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités

Tout ce qui concerne les logiciels lié au HC sur ordinateur (PC, Mac, Linux...)
Règles du forum
Avant de poster, merci de prendre connaissance des règles du forum : à lire avant de poster

Noirs bouchés et blancs brûlés avec Fraps

Message » 27 Mar 2012 21:30

Bonjour à tous (enfin j'ai l'impression qu'il n'y a personne sur cette partie du forum :hein: ),

Ou plutôt bonjour à celui/celle/ceux/celles qui verront mon message :lol:


En fait j'essaye d'aider quelqu'un qui a un problème de noirs bouchés et de blancs brûlés en faisant des enregistrements de jeux avec Fraps. Sauf qu'on trouve peu d'indices sur internet concernant la cause de ce problème :(

Voici un peu ce que ça donne chez lui (j'espère que les dimensions de l'image ne vous gênent pas :wtf: ) :

Image

On voit clairement que c'est bouché dans les scènes sombres et surexposé dans les scènes claires.


Bref, c'est bizarre, car chez moi aucun soucis. On a la même marque de carte graphique en plus (ATI). Donc je me suis dit que ça pouvait venir d'un codec. Je lui ai donc fais installer les K-Lite Codec mais pas de changements.

Voici ce que ça donne en tout cas chez moi en comparant YUY (16-235) et RGB (0-255) :

Image

A part légèrement moins de nuances dans les couleurs de part le passage de 0-255 à 16-235, aucun problème de noirs bouchés ou blancs cramés.

Vous me direz, il pourrait enregistrer en lossless RGB sauf que ça prend plus de place. Et puis ça ne résoudrait pas véritablement ce problème :lol:


D'après vous, d'où ça pourrait venir ? En plus de vouloir l'aider ça m'intéresse aussi grandement de comprendre :-?


Merci d'avance pour votre aide :wink:
Dernière édition par SuperLumberjack le 01 Avr 2012 4:17, édité 1 fois.
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Annonce

Message par Google » 27 Mar 2012 21:30

Publicite

 
Encart supprimé pour les membres HCFR

Message » 28 Mar 2012 9:06

C'est sûrement une histoire de mapping 16-235 / 0-255.
Mais avec Fraps il enregistre une vidéo ou juste une image ?
Fraps doit enregistrer en 0-255 je suppose donc si l'écran est configuré en 16-235 il va y avoir des noirs bouchés et des blancs brulés.
Et les images/vidéos sont jouées sur une TV ou un écran PC ?
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 28 Mar 2012 9:14

Je viens de tomber sur ce lien et j'étais pas loin :
http://frapsforum.com/threads/fix-dark-fraps-videos.758/page-2#post-3265

It's possible your playback application is making the video dark if it's treating Fraps
videos as "TV range". It may be possible to tweak your application to correct this (specify
"source" or "input" video as "Full Range" or "0-255"). If not, you may have to try another
application - like VirtualDub or XMedia. If you crank up the brightness on your Fraps video
and you don't see any more detail, (the black parts turn gray but look flat), your codec is
probably the problem...


Voilà ce passage dit que si ton logiciel de lecture traite les vidéos issues de fraps dans le mapping TV soit 16-235 alors qu'apparemment elle seraient en 0-255 et que tu lies ces vidéos sur un écran PC qui lui est en 0-255 et ben tu vas perdre les infos entre 0-16 et 16-235 donc noirs bouchés et blancs brulés.
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 28 Mar 2012 11:11

sauce a écrit:C'est sûrement une histoire de mapping 16-235 / 0-255.
Mais avec Fraps il enregistre une vidéo ou juste une image ?
Fraps doit enregistrer en 0-255 je suppose donc si l'écran est configuré en 16-235 il va y avoir des noirs bouchés et des blancs brulés.
Et les images/vidéos sont jouées sur une TV ou un écran PC ?


Avec Fraps il enregistre des vidéos :wink: Ouai c'est sur PC en fait. Pour être plus précis, par défaut Fraps enregistre en YUV, donc 16-235. Mais tu peux activer une case "force lossless RGB capture". Dans ce cas là ça enregistre tout en RGB 0-255, mais ça prend plus de place et ça peut être moins fluide.

sauce a écrit:Je viens de tomber sur ce lien et j'étais pas loin :
http://frapsforum.com/threads/fix-dark-fraps-videos.758/page-2#post-3265

It's possible your playback application is making the video dark if it's treating Fraps
videos as "TV range". It may be possible to tweak your application to correct this (specify
"source" or "input" video as "Full Range" or "0-255"). If not, you may have to try another
application - like VirtualDub or XMedia. If you crank up the brightness on your Fraps video
and you don't see any more detail, (the black parts turn gray but look flat), your codec is
probably the problem...


Voilà ce passage dit que si ton logiciel de lecture traite les vidéos issues de fraps dans le mapping TV soit 16-235 alors qu'apparemment elle seraient en 0-255 et que tu lies ces vidéos sur un écran PC qui lui est en 0-255 et ben tu vas perdre les infos entre 0-16 et 16-235 donc noirs bouchés et blancs brulés.


Ouai, j'avais lu cette page. Mais j'ai essayé de changer les réglages de ffdshow vidéo en testant en 0-255 et en 16-235 et en fait ça ne changeait rien a la chose :-? Ou alors j'ai loupé un truc. Déjà ça me parait bizarre que le logiciel de lecture ait à voir avec l'enregistrement de vidéo. Ou alors ça a un lien direct avec les codecs, c'est ça ?

En tout cas j'ai essayé de configurer ffdshow vidéo pour essayer d'obtenir le même problème que lui, mais pas moyen. Je vais encore tester pour voir.


Ben merci à vous 2 pour votre réponse :wink:
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 28 Mar 2012 12:03

Je n'arrive vraiment pas à avoir le même problème que lui. Je suis arrivé à avoir des noirs bouchés et blancs brûlés (un peu artificiellement faut le dire car j'ai réglé les niveaux manuellement :mdr: ) en lecture de la vidéo, mais en enregistrement ça ne change rien.

Je ne sais vraiment pas d'où ça peut venir :(
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 28 Mar 2012 13:21

Bon, j'ai ressayé tout un tas de truc, mais je n'arrive toujours pas à avoir le même problème que lui au niveau de l'enregistrement. Ça doit être très subtile comme truc. D'ailleurs apparemment personne n'a encore vraiment trouvé de solution.

Ça m’énerve de ne pas trouver de solution. En tout cas je pense que soit c'est au niveau du codec lui-même qu'il y a un soucis, soit ça vient de réglages de la carte graphique, ou soit il y a un conflit entre les 2. Qu'est-ce que vous en pensez ?
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 28 Mar 2012 21:03

Tu pourrais me filer un bout de video ?
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 28 Mar 2012 21:29

SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 29 Mar 2012 17:22

Alors ? Une piste :lol: ?
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 29 Mar 2012 23:24

J'ai l'impression que la base du problème c'est qu'il y a simplement absence de conversion des valeurs RGB de 0-255 à YUV 16-235. En fait ça passe simplement de 0-255 à 16-235 donc sans conversion, ce qui fait que ça tronque les valeurs en dessous de 16 et au dessus de 235.

Est-ce que vous auriez une idée d'où ça peut venir SVP :wtf:
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 30 Mar 2012 9:11

Désolé j'étais persuadé que je t'avais répondu :(
En fait j'ai plutôt l'impression que c'est le décodage FPS1 (codec utilisé par Fraps) de ffdshow qui fonctionne mal.
En effet si j'utilise celui de ffdhow j'ai les noirs bouchés par contre avec celui de LAV video c'est nickel.
J'utilise bien sur les même réglages sur les 2 (je sors en YV12) et rentre dans madVR qui est en 0-255.
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 30 Mar 2012 12:36

Il n'y a pas de soucis. Merci :wink:

Le soucis c'est que lorsque moi-même je fais des vidéos avec Fraps je n'ai pas de noirs bouchés. Quand je lis la vidéo c'est nickel. C'est pour ça que je me dis que ça vient plutôt de l'encodage et d'une mauvaise conversion de l'espace de couleur.

En tout cas chez moi, avec ffdshow ou sans, sur mes vidéos il n'y a pas de noirs bouchés. Mais sur les siennes si :(
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline

Message » 30 Mar 2012 14:56

Vous avez bien la même version de Fraps et de ffdshow ?
J'ai lu justement que certaines versions de ffdshow étaient bugguées niveau décodage du FPS1 mais aussi dans des version de Fraps.
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 30 Mar 2012 15:36

Bon j'ai trouvé le problème grace à madVr.
madVr sait me dire si je lui donne une vidéo full range (0-255) ou TV raneg (16-235).
Et ben avec ffdshow il me dit TV range et avec LAV video il me dit full range.
Et je lis de partout que FRAPS enregistre dans un codec en full range 0-255.
En fait ffdshow donne une mauvaise information au renderer. Il devrait lui dire que la vidéo est full range or il dit que c'est du TV range donc les 0-16 et 235-255 sont tout simplement ignoré.
Dis à ton pote d'installer LAV video qui lui donne la bonne information.
sauce
 
Messages: 1700
Inscription: 10 Fév 2004 15:44
  • offline

Message » 30 Mar 2012 17:12

Donc aucune info couleur perdu ? Ben merci beaucoup sauce. T'es un bon :wink: Je connaissais pas ce truc. C'est quoi exactement LAV video ?

Mais comment tu expliques que moi par contre je n'ai pas ce problème :wtf: ? Et donc, pour vraiment être sûr, au niveau de l'enregistrement ce sera sur le bon espace de couleur ou bien ça concerne uniquement la lecture de la vidéo ?
SuperLumberjack
 
Messages: 3138
Inscription: 26 Aoû 2005 21:45
Localisation: Alsace (67)
  • offline



Retourner vers Logiciel PC Home-cinéma

 
  • Articles en relation
    Dernier message