Modérateurs: Staff Home-Cinéma, Staff Juridique • Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 10 invités

Toutes les solutions à base d'ordinateur (PC, Mac, Linux...)

Saccades en lecture HD

Message » 28 Déc 2010 18:39

Bonjour à tous,

Je poste enfin mon problème car cela fait un moment que j'y suis dessus sans trouver de solution.

Je possède une nouvelle config à base de Core i3 530 et Windows 7 x64, un ampli Onkyo TX-SR507, un téléviseur Sony KDL-46V550
Problème : Je n'arrive pas à obtenir la lecture de flux HD synchronisé, fluide et sans saccades.
Le problème était identique sous config Athlon X2 245 avec CG ATI HD5450 DDR3.

Logiciels utilisés :
- FFdshow rev 3661 x86 & x64
- MPC-HC 1.4.2758.0 x86 & x64
- WMP sous Media-Portal 1.1.2
- Pilote graphique Intel : Win7Vista_64_15212

Logiciels non utilisés
- XBMC (DVDPlayer) car celui-ci ne gère pas les flux audio HD donc il m'intéresse moins. J'ai aussi des saccades avec lui.
- madVR (faut que je teste maintenant que j'ai la puissance CPU))
- Reclock car il ne gère pas les flux audio HD.

Je configure MPC-HC pour qu'il change la fréquence de mon récepteur selon le film (24p en général).
J'ai testé avec FFDshow Video decoder et DXVA sans filtrage. Le taux d'occupation CPU peut monter à 40% sans DXVA.
J'ai également testé les versions 64-bit car n'utilisant pas Reclock, la chaîne est toute en 64-bit.
Pour être sûr, j'ai réinstallé Windows 7 et aucun autre logiciel n'est installé, même pas d'anti-virus.

Se peut-il que mon ampli Onkyo TX-SR507 pose problème ?
Le seul "truc" que je n'ai pas testé est d'installer la version 32-bit de Windows 7. La version 64-bit peut-elle poser problème ?


J'espère que vous saurez m'aiguiller afin de trouver la solution à mon problème.
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Annonce

Message par Google » 28 Déc 2010 18:39

Publicite

 
Encart supprimé pour les membres HCFR

Message » 29 Déc 2010 0:17

Une capture d'écran :
Image
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 1:38

Là, le soucis,c 'est le framerate de ta video. Il est en dessous du framerate de l'écran.
Quels filtres as-tu d'activé dans ffdshow?
lulu78fr
 
Messages: 880
Inscription: 20 Oct 2001 2:00
Localisation: 78
  • offline

Message » 29 Déc 2010 1:52

Aucun. La capture provient d'une lecture en mode DXVA sans shaders d'activés.

Le framerate évolue et tend vers 24 comme les courbes vertes et rouges qui se rejoignent puis lors d'un changement de plan par exemple, ça "saute".
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 10:25

As-tu testé ta chaine en 32 bits ?
Ta carte graphique est une Intel je présume, elle est peut être un peu light pour faire du DXVA :-?
Quand tu dis que ta charge CPU n'excède pas 40% tu parles en général ou bien sur chacun des cores ? C'est possible que tu en es un qui sature
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline

Message » 29 Déc 2010 15:45

Comme indiqué dans le premier post, j'ai testé MPC-HC + FFDShow en 32-bit et en 64-bit.

Je possède un Intel Core i3 530 qui intègre le chipset graphique. Je suis à 10%/20% d'utilisation CPU en DXVA (voir capture du post précédent).

40% c'est le max affiché par MPC-HC.
Voici une capture de l'utilisation des threads en mode NON DXVA :
Image
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 15:51

Il monte quand même haut ton 3ème core, certains te diront qu'un core occupé à plus de 70% peut provoquer des ralentissements.
T'as essayé une autre version de ffdshow ?
Sinon dans ffdshow, quelle valeur as-tu mis dans "Nb thread du décodeur" qui se dans "option du decodeur" ?
Normalement tu devrais avoir mis 4, essaies de mettre 3 pour voir

Dernière question, dans ton Bios tu as bien désactivé tout ce qui concerne la gestion de l'énergie ?
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline

Message » 29 Déc 2010 16:38

Bon je savais que j'aurais dû faire ma capture en mode DXVA. Voilà :
Image

J'ai bien 4 threads sous FFDShow. Vu que sous DXVA le problème subsiste ce n'est pas le soucis.

J'ai désactivé C1E et le Speedstep dans le BIOS. Le mode Performances Elevées est sélectionné sous Windows 7.

J'ai mis la dernière version de FFDShow.
Les personnes qui ont un rendu fluide sous Windows 7 x64, SANS reclock, peuvent-ils me dire quelle version ils utilisent ?
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 16:40

Vous aurez noté une perte de trames. Ce nombre croit avec le temps. :(
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 16:42

Pour le DXVA, je ne sais pas ce que vaut l'IGP de Intel, il est peut être un peu light
Sinon tu as essayé un autre renderer dans MPCHC ?
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline

Message » 29 Déc 2010 16:49

Ca m'étonnerait que l'IGP ne suive pas. Et puis j'avais le même soucis avec du HD5450.

Sinon tu as essayé un autre renderer dans MPCHC ?

Non. J'attendais une autre solution mais si elle ne vient pas, je vais tester le MadVR.
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 16:53

Tu sors avec quel renderer actuellement ?
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline

Message » 29 Déc 2010 16:58

EVR Custom Pres.
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19

Message » 29 Déc 2010 17:01

T'as essayé le Vsync alternatif ?
Avec ou sans D3D d'activé ?
Aero activé / desactivé ?
princedeuphore
 
Messages: 559
Inscription: 24 Mar 2005 15:51
Localisation: Lyon
  • offline

Message » 29 Déc 2010 17:06

Vsync ne change rien, D3D non plus mais je n'ai pas de tearing et je veux utiliser la fonction Fullscreen !

Je vais désactivé Aero mais c'est idiot puisque mon chip graphique est suffisament puissant.
M. W. I. Prod.
 
Messages: 117
Inscription: 19 Juin 2005 2:19


Retourner vers Matériel PC Home-cinéma

 
  • Articles en relation
    Dernier message